Crashes when opening a CMYK or gray jpg file

MacOS. When I try to open certain jpg files Shotcut closes itself inmediatly after I click on the file I want to open. But it doesn’t crush when opening other jpg files or even the problematic jpg file if I have previously modified its proportions using the image editor… But in that case Shotcuts shows 4 repeated and distorted images. I’m unable to understand the logic behind this. Thank you in advance!

Do those certain JPEG files contain Meta data (EXIF)?
If so, try stripping all meta data first.

I suggest this as photos with exif intact always crash Google’s Nik Collection.

Thank you, Steve! I tried and stripped the EXIF data (which the JPEG file indeed contained) but Shotcut it is still crashing when trying to open it… (I have copied the failure report that pops up, but I don’t know how to read them).

Why would you report a bug about “certain height/width” and then not even supply that width and height?!?

Hahaha! I know, it sounds silly. And it is. But even so I did it -not providing the exact measures- for one (muddled) reason (hold tight):

I thought the crash would have other explanation than my “certain height/width” theory because, although from my clueless perspective that seemed to be the only reason, it didn’t make much sense to me because this crash has happened when trying to open other JPEGs (not all of them, but always the same ones) having all of them different, even opposed proportions (one was clearly “horizontal” while the other was clearly “vertical” so to speak). So one could ask “How did he even come to that conclusion? How did it even dawn on him to change those measures arbitrarily?” That’s because the first image that gave problems (an horizontal image) didn’t crash the program but it appeared distorted (compressed as a vertical stripe) and quadruplicated to fit in the player (each stripe separated by a thin blue line -although this image was b&w… I don’t know, I just give you details that may help to elucidate what happened) so after many unsuccessful repetitions I thought “May be this image is ‘too horizontal’” (I know… it’s a contra-intuitive and desperate thought) so I opened it with GIMP, added (roughly) some height altering the canvas size, reopened it with Shotcut and it worked! It didn’t quadruplicate nor distort. But the next JPEG I tried to open did crash the program and it was “vertical” so I made it more horizontal (it sounds nuts) and it opened!.. But when the third one (similar to that last) started to crash even when i changed its measures I gave up (think all those mishaps are experienced with tantrums and deep helplessness due to my general ignorance of computing). Well, I don’t know… Before all this happened I had opened without any problem various photos (also JPEG, all in different measures). Those that gave me headaches were scanned and modified drawings…

Thank you for your attention and above everything thank you for programming this open access tool and recording the tutorials!


Finally it turned out to be the image color mode! The images that gave problems were grayscale mode, but when I changed them to RGB they opened without crashing. As all the images were grey, but only some of them crashed the program I did’t understand what was going on.

Thank you for sharing that. I will see if it is possible to detect that and do something about it.

Same here except that original was CMYK — changed to RGB & everything worked fine.

Cheers, everyone, for the help.

Today, I tried to reproduce on Linux, macOS, and Windows Shotcut versions 18.03 and 19.07, and I could not. I created CMYK from a RGB/YUV JPEG using ImageMagick convert in.jpeg -colorspace CMYK cmyk.jpg. (MediaInfo reports this as YCCB.) Similarly, I created a grayscale with convert in.jpg -colorspace gray gray.jpg. I also tested grayscale with an odd width. I need someone to upload a file that demonstrates the problem in order to fix this.