Crash with a specific ".cube" 3D LUT

Hi there !
I was playing with my new Mavic 2 Pro drone, trying its DLOG-M for video recording, and hence wanted to try the official DJI (the drone manufacturer) 3D LUT to post-process the capture.
Unfortunately trying to apply this LUT on any video (not only those I shot) causes Shotcut to crash. Other free LUTs found on the web work perfectly, so I am wondering why this one is having issues.
For the records I am using Shotcut 18.09.16 on Windows 10 Pro 64-bit,
Here is the link to the DJI “.cube” file:
Can anyone see what is wrong with it?
I am currently trying to set up a Shotcut dev environment on my machine to check the problem by myself but being used to Visual Studio on this platform I think it’ll take me hours (if not days :-P) to get there !!!
While I am at it, thanks a lot to the whole team for this wonderful sofware.

The crash is fixed for the next version 18.10, but that LUT fails to load because the FFmpeg libavfilter, which Shotcut uses, complains: [filt @ 0000000055601dc0] 3D LUT is empty
I do not know why. I tried to edit the .cube file in a text editor to make it resemble cube files that work as much as possible, but that did not work.

Thanks for the information - it looks like it will be even more complex than I thought to debug. :stuck_out_tongue:
BTW, is it normal that I cannot download the Shotcut SDK (I get an access denied XML response) when following the instructions found on ? Is there an alternative download link?
Thanks again for your help!

No, the version number in the link was bad. I fixed it, but the page might be cached; so here it it is:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.