Crash when use track audio and gain filter

What is your operating system?
I’m Using:
Operating System: Linux Mint 20.2 Cinnamon
Cinnamon Version: 5.0.7
Linux Kernel 5.4.0-91-generic
Processor: Intel© Core™ i7-6500U CPU @ 2.50GHz × 2
Memory: 16GB
Graphics Card: Intel Corporation Skylake GT2 [HD Graphics 520]

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Shotcut version 21.1031 64bit

Can you repeat the problem? If so, what are the steps?
Shotcut crash frequentlly when with audio track and use the Gain filter, after changed the filter property, every action I make after that, shotcut crashed…
So I must save after every action to avoid lost my changes… and is this furstating

I add the Audio Track when I finished to edit my video, and while edit my video shotcut works fine.

I made a short video:


Thank you for the video. That is helpful.

But I do not recreate this in my simple test case:

  1. Start with empty project
  2. Add Video track V1
  3. Add Audio track A1
  4. Open video clip and add to V1
  5. Open audio clip and add to A1
  6. select audio clip
  7. Add “Gain/Volume” filter
  8. Change the “Level” parameter
  9. Seek around in the project

Shotcut does not crash for me like you show in your video. Maybe there is a step I am missing? Or maybe there is something else about your project that makes it crash.

Can you provide a bare minimum project that demonstrates the problem?

Hi Brian,
my projects are length more then 5 minutes… and maybe is when the project is huge, see attachment.

In this case the video length is 16 minutes, but I get the crash also with smaller video.

I can send you the project in the video… but is 8Gb in compressed mode… How can I send you the projects?
Do you have a FTP where I can upload the project?


There’s no need to send the original files that you used in the shotcut project. He just needs a simple .mlt file to test.

Like the person uploaded his file in the post:-

What happens when you post MLT?

OK, I send you the .mlt used in my project…

Ravenna.mlt (337.2 KB)

If I remove the last audio track, see screenshot:

Than I re-added it to timeline and change the gain… so when click another part of video (in Timeline) shotcut crash.

For me is unusable the software when I add the soundtrack and I work with gain to set level.

Is possible to enable a log that help to understand which is the crash?

I found the Log and attach it to this message.

I think there aren’t message that can help to solve the crash when editing the gain filter when I change the selection

shotcut-log.txt (56.4 KB)

The original video doesn’t match the screenshot.
The MLT file you uploaded has an audio transition, whereas in the original video it doesn’t.

The log you uploaded appears to be from a different MLT project.
The log file re-writes itself each time Shotcut is closed/restarted.

Have you tried to recreate the bug with a simple project that @brian has listed out in post #2? Will that simple project crash for you? If it does, upload that MLT with the Shotcut log file.

The MLT is a recent project. I get the issue also with the new project.

The issue happens when the project starts to get “complicated” with several video / audio / filters, not with simple like your test case.
See my screenshots in previous replies

Can you share more information as to which filters are you using when it starts to get “complicated”?

Also, please share the following information, such as Video Mode (Displayed in Properties, after clicking on Output in the timeline.

And information on the video clips you are using. Are they all of the same resolution/fps?

For complicated mean when the .mlt contains a lot of video like the mlt into the log files I posted.

The filter that I used are mainly the same:

  • Timelapse
  • Gain
  • Mute
  • Text
  • Fade in/Out

and I get the issue when changing the gain into the Audio Row:

To avoid lose my changes I must save after every action I make

The Video Mode is:

and I’m using the same Video format as Input (COOAU Action cam):


I’m using also images or files audio (from Youtube Library):

Let me know if you need more informations

It’s highly possible that the mismatch of 30.00000 FPS from your Video Mode and the source video being 24.975025 could be causing all of the issues. In the MLT you uploaded, there are many clips where you have sped up the video clips.

The Video Mode for your project doesn’t change. It’s not variable. So for video files not of the same fps Shotcut has to adjust on the fly for each frame to the Video Mode. ~25 Frames of your source video doesn’t really equal 30 frames of the Video Mode. For each filter you apply to a video clip, Shotcut has to adjust to the Video Mode.

Have you tried to convert your video(s) to Edit-Friendly? Shotcut has a built-in conversion tool.

Thanks so much for your technical answer. I’ll try with next video!

Can I change the output format to 25FPS to try solve the issue?


Only one note… in this case all the video came from my action cam Cooau CU SPC06, while sometime I use my phone to make video (an HUAWEI P20 Lite) and with these videos, shotcut tells me to Convert Edit-Friendly every single video.

Is possible to get the convert message also in this case?

Click on “Properties” for the video and at the bottom of the pane you will see a tab that says Convert…, click on this and you will be able to convert the file to “edit-friendly”.

Update: With my last video… I didn’t get any problem with gain filter…

Maybe is the last shotcut versione 22.06.23 or that I begin to make 4K videos… I don’t know…

1 Like