Crash, update, crash again

Howye! It’s been a month or so since I started up Shotcut- and today, it is crashing every time I open a video.

I had been using version 22.04.xx, and after the crash, updated to 22.12.21. I also did a Windows update, to put me at Windows 10 Home, 64 bit, version 10.0.19044.

after reinstalling Shotcut and updating/restarting, I fired it up again. Same result. Open file, immediately crash.

Log file is attached. Thanks for any help possible. I vastly prefer Shotcut to the other program I will have to use if I can’t get it working!

shotcut-log.txt (33.9 KB)

What is the file type? An existing .mlt project file, or some type of video file to start a new project? There could be different problems depending on the type of file causing the crash.

Oops. Sorry, I should have mentioned that it was a .MOV file created by a cheap little GoPro knockoff. I tried opening shot cut then directly opening the file, and also tried opening the program, creating a new mlt project, then opening the file. Same result either way.

The file plays just fine in the stock windows player, and I was able to open and edit it just fine using Openshot, which I kind of hate using.

Unable to reproduce. Try some things and tell us what does work. All we know (log is not telling) is that you’re having a problem with this one video file that we do not have.

  • Try a different video from a different source.
  • Try Open Other > Noise. Does that work?
  • Reboot
  • Reset all settings (bottom of Settings menu).

I think it’s possible there may just be some issue with shotcut not liking that particular video. As I mentioned in my last reply, other programs had absolutely no problem opening it.

I will try the noise option today.

As mentioned, I have already done a reboot, so that is perhaps irrelevant at this point.

Resetting the settings intrigues me. Is there any specific type of setting that needs to be reset, or are we just looking to have any random various other option checked in any case, just to try to jog something? Hard for me to say anything definitive, as I am not looking at the settings menu right now.

I’ve used for a long while a gopro knockoff (Evolio 4K it’s called but it’s based on the Eken H8 firmware) that creates .mov files and have been editing them fine in Shotcut.

Is it just this one file or do all files from this camera crash the app? If all of them, try recording a small 10 second clip and upload it here.

No, all: Settings > Reset…

Oh, gotcha. I misinterpreted, as I’m not sitting in front of the software. All settings, reset makes sense.

I was thinking upgrading to a new version might have reset some settings, but now that I think of it, it should have just updated the programs operational files, and not reset my settings. (Isn’t there a checkbox for whether to blow out personal settings and such?)

I haven’t yet tried another file from the camera. I will try using it again today, and see if another file has the same result.