Crash on open video file v.180503 /Win64 (probably during auto-resize of project image size dimensions)

Just installed Shotcut 180503 in Wind 64 (windows 10) on top of previous install, so some settings may have been inherited (however, this problem did not occur for me previously).

Steps to reproduce:

  1. Install Shotcut 180503 on Win 10 64-bit
  2. Start program.
  3. Press ctrl-O, or push button Open file, to open video file and select one or several .mp4 files to open. I tried opening both from my hard drive (actually SSD) and directly from SD card.
  4. In a second, the timeline will reflect the length of the selected clip.
  5. Then Windows tells me that the program has crashed.

I don’t have development tools, but am an in general an advanced computer user, so would be happy to help with additional troubleshooting if needed.

I’ve been doing this most of the weekend, well since the update of 18.05.03. No crashes on my end.
Although I haven’t tried opening from an SD card, although I’m not sure why I would want to open from an SD card.

Thanks. For the moment I’ll revert to v 180306
Another day I’ll give it another shot, make sure to restart the computer etc. Might be some external dependency that’s failing.

Reverted to 180306, now works fine, without rebooting the computer.
I’ll analyze deeper another day, too time-constrained today.
Thanks!

FYI: I do this frequently when I have a short clip of something random I want to send to a friend or post on FB. Never any issues.

1 Like

@tobif for me 180503 crashes when I import one of many video clips. Can you try importing a jpg photo (the size of your video) first or can you try setting a video profile (settings/ video mode) first and let us know whether that solves it for you too?

Great, @qubodup
When I open Shotcut and leave video format as Automatic, it crashes when I open an .mp4 with image size 1280×720.
But if I first choose project image size, then it all works well.

First opening a .jpg with same image size works well and sets the project image size correctly. After that, I can safely open the video file.

I also tried recoding the video into .mkv. and .avi I get the same crash here when I try to open these video formats as first thing in my shotcut session.

Same here: v 18.05.03. Brings up Visual Studio debugger.

Tried both 32- and 64-bit Windows versions from installer; both have problems.

I’m not experiencing these issues, I wonder what’s different about my 6-core Phenom, W10 Pro 64bit system, 20Gb DDR3, SSD boot drive, 3 SATA platter drives, 3 USB 3 externals, R7 360 2Gb Radeon.

1 Like

I’ve been trying to duplicate the issues discussed in here, but can’t. Perhaps the people that are having real issues can give real information about their systems to help find a solution to the problem.

Before I upgraded to 18.05.03 I had set “Display Method” to OpenGL since I have a NVIDIA graphics card.
Previously it was set to Direct X, but when I changed to OpenGL I didn’t notice any improvements nor have I experienced any crashes. I have a game that demands OpenGL 3.0, and Shotcut only requires OpenGL 2.0.

I’m not sure the Display method will solve any issues but I thought I would throw that out there as it may help someone.

Below are my computer specs and Settings within Shotcut, as I do have GPU Processing turned off. I was experiencing crashes with GPU processing when it was turned on.

OpenGl

video mode

audio ch

Software Environment:
Windows 10 Home 64-Bit Version 1709 KB4093112 (OS Build 16299.371)
OpenGL 4.6.0
DirectX 12
NVIDIA 397.31
GeForce Experience 3.13.1.30

Shotcut’s minimum system requirements

CPU: x86-64 Intel or AMD; at least one 2 GHz core for SD, 2 cores for HD, and 4 cores for 4K.

Computer Specifications:
i7-7700K Kaby Lake Quad Core 4.2 GHz (4 Cores, 8 Threads)
ASUS ROG GeForce GTX 1070 08G STRIX (8GB 256-Bit GDDR5)
ASUS ROG Maximus IX Hero Z270
G.Skill Ripjaws V 32GB
CPU Liquid Cooler AIO
EVGA SuperNOVA 750W Platinum

Once again, as I was typing this out, @Steve_Ledger beat me to the punch with the system specs.

My specs and settings:
OS Name Microsoft Windows 10 Home Single Language
Version 10.0.16299 Build 16299
System Manufacturer Acer
System Type x64-based PC
Processor Intel® Core™ i7-5500U CPU @ 2.40GHz, 2401 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date Insyde Corp. V1.37, 2016-02-16
SMBIOS Version 2.8
Embedded Controller Version 1.08
BIOS Mode UEFI
Secure Boot State On
PCR7 Configuration Elevation Required to View
Locale Sweden
Hardware Abstraction Layer Version = "10.0.16299.371"
Installed Physical Memory (RAM) 12.0 GB
Total Physical Memory 11.9 GB
Total Virtual Memory 20.9 GB
Page File Space 9.00 GB
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Shotcut settings:
GPU processing: Off
Scrub Audio: Yes
Realtime (frame dropping): Yes
Progressive: Yes
Deinterlaces: One field
Interpolation: nearest neighbor
Theme: Fusion dark
Display method: DirectX (Angle)

Audio channels: 2

This might be a bit off topic.

Might want to check with Acer to see if you have a BIOS update waiting for you. I doubt this will fix the issue, but at least you’ll get the patch update for the Sceptre/Meltdown vulnerability.

From all of the various video content about this, I thought you couldn’t get the latest builds of Windows 10 unless you had the BIOS upgrade as Windows was supposed to check for it.

Here just one of hundreds of articles on the BIOS updates.

And from that website, is this link to Acer on the same issues. (last updated 5/3/18)
https://us.answers.acer.com/app/answers/detail/a_id/53104

Thanks. Looks as if a BIOS update is due in June.

Face it, guys. The new version has a bug. Reverting to the old version, which I did, restores normal operation.

The bug is being tracked on Github:

The bug is a race condition, which is why some experience, others do not, and some intermittently.

2 Likes