Copy / paste rich text misaligned

version 23.12.15 windows 10

When I copy a rich text filter to place on top of same text,I would expect it to paste directly on top of… but it never aligns. all positioning and sizes are identical Seems to work ok with simple text. Is this a bug or am i doing something wrong.

I can duplicate the same issue
Appears to be just a preview bug when one filter is selected.

Deselecting the filter will show that the filters are not misaligned.
I exported a frame to confirm both filters are not misaligned.

(Not related to the bug you reported) Are you working with video that’s over 100fps? Your timecode appears to indicate that, or perhaps your video has a variable frame rate.

1 Like

Ah thanks… just did the same…looks wrong on preview but fine after export. Re: fps. I’m new to all this. It’s an iphone vid (30fps) video mode set to automatic in shotcut

Typically cell phone videos are recorded with a variable frame rate. Shotcut only exports to a constant frame rate. There is a convert button in Shotcut (found on the Properties panel to convert your video(s). This converts them to Edit Friendly (actually creates a new video file for you to work with).

The problem with Automatic is it’s only good for the first clip you bring in. If your first clip is 30.184332 fps, and the next clip is 30.192304, the Video Mode FPS will only be what your first clip is set to. You can set your Video Mode in Settings. A good FPS will be 30.000000.

The problem with variable frame rate video from a video editor standpoint is many times things don’t align, frames may get added/deleted when you don’t want them to.

If you look through your phone’s videos, you may see a different FPS for each video.