Computer shuts down while editing in Shotcut (not overheating)


A little help would be appreciated, please.

While using Shotcut - and in no other circumstances - my PC shuts down without warning. It’s not a normal shut down, i.e. operating system closes properly - it’s as if there’s a power cut.

It happens under the following circumstances:

  1. playback of a video that’s being edited
  2. copying a clip to the timeline.
  3. adding filters, etc.

Unfortunately, I cannot therefore point to a single action that triggers a shutdown.

Further points to note:

  1. there’s no evidence that the computer’s overheating (far from it)
  2. AMD Ryzen 9300X, 64GB RAM, Navidia GTX 1660 Super
  3. Shotcut version 20.07.11 (on Ubuntu 20.4).

Thank you for any suggestions.

It is not a Shotcut bug; the kernel does not allow a userspace application to do this no matter how buggy it is. This is a problem with a driver or your hardware. Shotcut is maybe the most intensive software you are running that exercises many aspects at the same time. You might be able to see what is going on by looking in some logs in /var/log such as dmesg or dmesg.0. You should run a memory test as well; Ubuntu live/install images have a memory tester in their boot menu.

Have you tried changing your Display Method? (Settings - Display Method)

What are the file specifications of your source clips? (Resolution/FPS)
What is your video mode set at? (Click on Output/Master, then Properties)

Thank you.

Thanks for your reply.

Haven’t tried changing the display method. On my PC, there’s a choice of ‘Open GL’ or ‘Software (MESA)’. It’s set to the former.

As for my clips, they’re 1920 x 1080 and 59.95 FPS.

If you are using the nvidia binary driver the software OpenGL method will not work. That only works with Mesa-based OpenGL drivers. If you are using nouveau then I think it should.

Thanks again for your reply.

When I installed Ubuntu 20.4, Nvidia X Server Settings installed by default. I haven’t made any changes. Under the ‘X server information’ tab, it says the Nvidia driver version is 440.100.

Is that the ‘Nvidia binary driver’? And, if so, might I be better setting Shotcut display method to ‘software’?

Yes, that is the nvidia binary driver: Ubuntu – Details of package nvidia-driver-440 in focal

I am not aware of a software only mode for this driver, and you should not need it either. For many years I used nvidia all the time without a problem, and it was always the best OpenGL I could get on Linux. But I have not been using it for a couple of years. I hesitate to suggest switching to nouveau because sometimes it is a messy process and require some manual fixing and cleanup.
However, as you can see in this search there are a few different versions of nvidia you can try. From my previous experience, Ubuntu was cleaner at switching versions.

Thanks Dan. You’ve been very helpful.

Shotcut is great software so hopefully I can get this issue sorted.

In my Experience this happens with a faulty GPU. I have seen a machine which would abruptly restart when a GPU load was added to it. If I did not do anything GPU specific and turned off Transparency in Windows, It could run for a week straight without crashing.
Unfortunately it turned out to be a Hardware issue, Like some Encoder Chip or Certain Transistors in GPU going bad.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.