Compiling Shotcut


#21

We do not want to change the default value of the filter. The default value is currently set to “no change”. We don’t want people to apply the filter and then see their colors all messed up. Instead, we need to change the scaling of the UI controls so that the user has a wider range to operate in.

I’m literally working on this right now. I am modifying all the spinners to go from -100% to +100% with 0% being “no change” (default).


#22

That’s great and it saves me a lot of work!

Here’s a tidbit of engineering nomenclature for you. This is known as unity, i.e. lift/gamma/gain * 1 and + 0. :slight_smile:


#23

Ran out of time tonight. Here is my WIP:
ui.qml.txt (18.8 KB)

I got the scaling to work for lift. You can see how it can go positive and negative. I need to whip out the quadratic formula for the gamma and gain. Will work on that next.


#24

@chris319 Here is my complete proposal. Would you be willing to test it?


#25

Yes, of course I would be willing to test it.

Give me a dumb-guy’s explanation of how to incorporate it into Shotcut. Do I need to copy a file and rebuild shotcut? What is/are the name(s) of the file(s) I need to copy?


#26

Since Dan has already merged the change, the easiest way to test it would be to download the latest nightly build:
http://build.mltframework.org/repository/download/bt43/60368:id/shotcut-win64-190113.zip

If you want to test and maybe modify the code changes in your build environment, you would need to install Git Bash. Then, in the Git Bash terminal, cd to the shotcut directory and then run:
$ git pull


#27

Hi Brian -

Downloaded and tested. Looks like it works well. At last, Shotcut has a functional lift control.

Still not seeing the scope graticule and numerals for whatever mysterious reason.


#28

That is very odd. I haven’t heard anyone else complain about it. But if it is happening to you, it could certainly happen to someone else.

The only two things I can think of are:

  1. Maybe you have configured the Shotcut docks in such a way that they interfere with the lines. Maybe try resetting the layout?
  2. Maybe there is something about the way it is programmed that doesn’t work with your graphics card?

If you are interested in experimenting, the relevant code is here:


Maybe try changing the order of things or making the lines thicker?


#29

I’m running Shotcut straight out of the box without adjusting anything, and there is nothing exotic about my graphics card or its installation.

I see the scope is in its own window. I expand that window as far as I can horizontally and still no graticule or numerals.


#30

Therein lies the mystery!

Hopefully you can fiddle with the code to find a hint about what might be going wrong in your environment.


#31

Try fooling around with the variable “textpad” on line 104

int textpad = 3;


#32

Great idea. Can you try it out? Since I do not reproduce the problem, there is no way for me to know if it has any effect.


#33

I’ll try it out but it will be a while, after I get back from work.


#34

I haven’t made any changes to the code yet, but now when I try to bring up the scope all I see is a black rectangle/window.


#35

Not only am I not seeing the numerals, I’m not seeing the graticule lines:

qreal ire100y = height() - (height() * IRE100 / 255);
p.drawLine(QPointF(0, ire100y), QPointF(width(), ire100y));

Could the problem be in the widgets.h file?


#36

This is normal until the next frame is played or current frame is refreshed even if it is not ideal.

Could the problem be in the widgets.h file?

That is a part of the Qt libraries we use for the GUI toolkit. It is a giant rabbit hole, and its source is not part of the SDK.


#37

Maybe not such a great idea. I’m having the same problem with both the lines and the text.


#38

I tried changing the textpad variable to 200 and bypassed the mutexes. Program compiles and runs OK but no joy with scope graticule. At the least the lines should show up.


#39

The scope graticule and numberic markings do appear in Linux.

They do not appear in either Windows 10 or Windows 7.


#41

This might have fixed your graticule problem: