Color dialog non-functional

I apologize if this has been asked before, I did search the forum and couldn’t find it.

Short version:
The color clip color picker does not seem to keep my changes, no matter what I do.

Long version:
I am trying to add text to a video clip as a separate video track. I go to “Open Other->Text”, type in my text, make sure the background color is listed as “transparent” (I’ve also tried setting it to have an alpha channel of 0), click “OK”, click the “+” to add to the video track, and the new clip has my text with an opaque black background. I’ve tried changing the colors in multiple different ways, including saving it as a custom color, and it always reverts back to black with an alpha channel of 255. (#ffffff in the HTML window).

I have been completely unable to find any information regarding this bug for anyone else.

My version is the latest, 20.07.11

Any help would be much appreciated.

Thank you.

What operating system? It has been reported as a problem when using ChromeOS or Wayland display on Linux.

See also Error - Color picker for chroma key does not work at all, sort of crashes shotcut

Windows 10, I can give you the exact version if you need it?

Oh, wait I see your report is not about the color eye dropper but about the color selection. But I do not reproduce it either.

Your steps are not clear:

the new clip has my text with an opaque black background.

I do not reproduce that; mine is transparent. But it is also the only thing on V1, and there is nothing to show underneath.

I’ve tried changing the colors in multiple different ways

There are 4 colors involved in Open Other > Text:

  1. Text
  2. Text Outline
  3. Text Background
  4. Properties > Color

it always reverts back to black with an alpha channel of 255.

By design, when you choose a new color, it changes the alpha to 255 because too many users starting with a transparent color did not change their alpha and reported color change is not working. So, yes, the alpha channel always reverts to 255 when you open the color dialog, but you can still change it and it shows up in the result after you click OK.

What I do reproduce is that the color dialog always opens with #ffffff and alpha 255 instead of the current color, but I can choose any color I want and set the alpha, and I get what I chose, which is hardly “non-functional.”

Show a screenshot of your color dialog with the color and alpha you picked followed by a screenshot of the Properties > Color and video preview.

Here are my screenshots

As you can see the color is “#0955FF00” which matches the color I chose.

That is fixed for the next version 20.09 due in September.

Steps to reproduce:

  1. Have multiple video tracks
  2. Have an open other->text
  3. Open the properties of the text clip
  4. Click the color button
  5. Change the alpha channel to 0
  6. Note that the clip is still opaque

N.B. This only seems to affect the “properties” color, changing the items under the text filter seems to work fine.

If you have any further questions, or any other way I can help figure this out, please let me know.


PS I tried to get a video of this, but my screen cap software isn’t working right now, apologies
PPS I also tried to get a big stack of screenshots, but I can only post one, so here’s the filter settings window, along with the opened and set (thought not OK’d) color picker from the properties tab (sorry about the MSPaint collage):

You have V1 hidden.
It also appears you have made all of the text filter colors 0 Alpha Channel

In my example I have default colors for the text filter, with V1 not hidden.

Ah! I see the bug now. I apologize, I missed the issue previously. So, new steps to reproduce:

  1. Have three video channels, two with different videos, and a third with the text
  2. Hide V1 (note, specifically V1)
    V2 also becomes hidden.

In the screenshots below (again, apologies for the Paint collage), note the tracks that are hidden vs. not:
Picture 1: All three tracks shown, V2 video is output, overlaid with the text track, V3
Picture 2: V2 hidden, V1 video is output, overlaid with the text track, V3
Picture 3: V1 hidden, no video is output, only V3

NB: The only changes between the three screenshots are which tracks are shown vs. hidden, no color changes, no time changes, just hiding/showing the three video tracks.

If this is the expected behavior, I apologize for taking up so much of your time, but thank you for helping me with this.

Was just messing around, found a new wrinkle:
If I hide both V1 and V3, V2 becomes visible:

So, overall behavior:

V1 V2 V3 Output
Shown Hidden Hidden V1 alone
Shown Shown Hidden V2 alone
Hidden Shown Hidden V2 alone
Shown Hidden Shown V1 and V3
Hidden Hidden Shown V3 alone
Shown Shown Shown V2 and V3
Hidden Shown Shown V3 alone