Color change of non-transparent clip


#1

In a composite track a nontransparent clip(with no filters) becomes opaque:

Source clip(http://editors-toolkit.co.uk/4-free-sample-exercises/):

[streams.stream.0]
index=0
codec_name=mpeg4
codec_long_name=MPEG-4 part 2
profile=Simple Profile
codec_type=video
codec_time_base=1/25
codec_tag_string=mp4v
codec_tag=0x7634706d
width=720
height=576
coded_width=720
coded_height=576
has_b_frames=0
sample_aspect_ratio=64:45
display_aspect_ratio=16:9
pix_fmt=yuv420p
level=1
color_range=N/A
color_space=unknown
color_transfer=unknown
color_primaries=unknown
chroma_location=left


#2

This is a confusing report. The link goes to a website that requires registration to download, which I don’t really feel like. What do you mean by “nonopaque clip?” There is no alpha channel in pixel format yuv420p in the info that you provided. Your animated GIF is hard to follow and textual descriptions are hard to follow.


#3

Sorry about that. The source material is an editing exercise. Quite fun to do edit tests in Shotcut with.

It might be this specific material which makes the colors/colorspace jump. I tried to do it with other material without reproduction of the problem. I’ve uploaded a zip with the mlt file and two clips to the Shotcut site.


#4

When I looked at the MLT XML of your project, I saw some “movit” properties on some producers, which means GPU processing. However, I see that the transition elements which are used for compositing/blending video tracks are using frei0r.cairoblend, which is what is used in CPU processing mode (GPU processing uses movit.overlay). If you open this project in CPU mode, then it works fine. If you open it in GPU processing mode, then it is using the wrong transition and shows this color difference when toggling the track composite button. This shows a couple of bugs: allowing it to be opened in GPU mode and some difference in RGB - YUV conversions. Moreover, this is reproduced in GPU mode only when Settings > Gamma is set to Rec. 709.


#5

Sounds complicated. I think you’re right, the project may have been started with GPU on and then switched off at some point. Thanks for looking into it.