Chromakey is not working after a certain timestamp, what is the problem?

So i applied ChromaKey to my greenscreen clip, and it doesnt work, but when i dragged it in front then it worked. I want the greenscreen to work on the clip intended previously. How do I fix this? Hoping for a quick answer as I have a deadline. Images shown below should help understand the situation I am in. Greenscreen not working at specifically 00:19:22:45. It seems i can only upload one image so I will upload the image showing that it is not working.

I came across a bug similar to what you are describing but I didn’t know how to reproduce it. It’d be nice if you can upload that specific mlt project file for the devs to look at it to see if they can figure out the bug fix.

What version number of Shotcut are you using?

Is the green screen a video or a picture?

idk how to check the version number but when i check for upgrades, it says i am using the latest version. The Greenscreen is a video.

MLT > Episode 1.mlt (135.8 KB)

Help > About Shotcut.

Okay. So try this workaround:

  1. Open a new Shotcut project.
  2. Bring that greenscreen video to the timeline.
  3. Apply the Chroma Key filter you want. If your video already has the same default kind of green as the default setting Shotcut has then you can skip to step 5. If not go to step 4.
  4. If you need to be able to adjust the values in order to get the green out then get a color clip in Open Other > Color and bring it down to V1 and put your green screen video on V2. Adjust the Chroma Key settings and when you get them the way you want then delete the color clip from V1.
  5. Go to the Export menu and pick from one of the presets in the alpha category. All those presets will export a video preserving the transparency so you won’t need to apply any Chroma Key. If the size of the file is not an issue than Quicktime Animation is very good but if you can’t afford a big file being exported then consider WebM VP9 with alpha channel.
  6. After the video is exported close that Shotcut session and repoen your project with the bug in effect. Bring the video you just made and drop it in the timeline.

Let us know if works.

Sorry but your steps did not work, I still do not know what’s wrong.

Though if you can see in the .mlt, i want to put the greenscreen clip at 00:21:20:29, on the Extras track applying to the Final track. If I enable vision on my Extras and Final track the screen will only show the green screen and nothing else, but if I enable one of the other tracks titled “Hurricane Cam”, the greenscreen is applied but there will be two screen shown in different sizes with Final being over “Hurricane Cam”. I’ve experimented and the greenscreen works ok after the timestamp mentioned above but only for “L1NF3RN0 Cam” and “Hurricane Cam”. I want it to work on Final, how do i fix this? Is it a bug?

Can you check using “Properties” that each track has Blend Mode set to “Over”?

Yes all tracks are on Over for the blend mode.

What part didn’t work? Did the video that you export not have transparency? Or did the video have transparency it’s just that when you placed the clip in the problematic spot on your project the same problem happened?

the latter, though the thumbnail of the photo clearly had transparency and no green, once i play the preview it shows just a green screen.

Ah, okay. This is something that the devs will have to look at then. Like I said I came across this same bug before but couldn’t figure out how to reproduce it.

What version number do you have? Look in Help > About Shotcut.

Have you tried starting a new video track right above the problematic track and see what happens when you try the green screen there?

Have you switched off (clicked on the EYE sysmbol) the very bottm track (V1). Greenscreen will not work if that is the case since it composits to the bottom track.

Ah, I fixed it myself. Thx for giving me a hint on what to do, i have 5 tracks, even though all the eyes were off except the track with the green screen and the track i want to apply the effect to, it still did not work. So i had an idea to just remove all the clip from the three other tracks directly below the clip i want to apply green screen to(I didnt need them so it didnt really matter), and it worked, hope you guys can make a feature to make green screening much easier with multiple tracks. Thx.

The reason it worked was that by removing the tracks at the bottom you had a new V1 track (Final) and it is this track that is used for the compositing. You have to have a visible V1 track for Green-screen to work - even if it is empty.

So, then this isn’t the bug that I cam across before. Mine was the same problem but there were no tracks that were deactivated. It was a legitimate bug that would not allow chroma key to work in a specific area. Glad you got it fixed though. :slightly_smiling_face: Feel free to remove the mlt track that you had uploaded then.