Choppy export after adjusting project frame rate

Hi everyone, thanks in advance for your time and suggestions. I use Shotcut almost every day and am thrilled with how it keeps improving and how I keep finding new things to try.

When I began a recent project I was not as vigilant as usual with selecting the video frame rate. I know that the frame rate of the project will be set automatically based on the first clip I import, and if my first clip doesn’t have a frame rate the default is 25fps. …

About half way through my editing I noticed that my project was set to the 25fps default, and (doh!) my intention (and my footage) is 29.97fps. I tried to switch this and immediately ran into trouble: playback on the timeline slowed considerably and the clips had all shifted themselves. In a panic I switched it back to 25fps, restarted the project, and this solved the shifted clips (but not the jarring playback).

I continued editing and hoped that during the export the issue would solve itself, but was disappointed with the final result: the video had lost its fluidity something terrible after being exported in 29.97fps. Since then I have been experimenting with varied versions of the same project: changing the project frame rate, restarting the project, and re-exporting, to no avail. I tried creating a new project at 29.97fps and importing the other and for a minute there I thought I had it working right, but again the export was not fluid. … it is as though it is still stuck thinking the project is 25fps.

It is strange to me because when I set other projects to 29.97fps at the beginning and import like clips, the resulting export is smooth as silk. But in my case of adjusting the frame rate late (during the course of the editing) I can no longer achieve this smooth result.

Any help or suggestions is greatly appreciated. I am using the most updated version of Shotcut. Could this perhaps be a drop-frame issue, or parallel processing? If I cannot find a fix for this I will have to re-edit the whole thing :frowning: , being certain to set the frame rate before I begin. Thanks again!

Also just tried adjusting the project video setting to the 29.97fps preset and then re-starting the project, not once but twice (as the adjusted setting did not seem to take on the export menu after first re-start), with a bizarre result. The video then became 4:10 on the timeline instead of 5 minutes long; playback was made up of the same clips but each with shifted content. I exported the video and the smoothness issue had been resolved, but the video itself was a completely different edit than my own, interesting but unfortunately not usable. I hope to get to the bottom of this!

It’s a choice to leave the Video Mode in automatic. Always better to select a video mode before opening any file, then your entire project takes on the video mode you want.
The most recent version of Shotcut is 19.08.16, which can be downloaded here. Operating system?

Click on Properties.
Click Master on the timeline. Can you drop a screenshot of this properties box into here?
Click on your 29.97 clip. Can we get a properties screenshot of this as well?
Do all of your other clips match properties?

Thank you Hudson555x for your quick reply. I realize the fault is my own, I do several projects a week and it is rare I forget to set the frame rate. Normally I would discard the work and start again, but in this case the timeline was unfortunately elaborate by the time I discovered my oversight. I do have the most recent version of Shotcut, thanks for that also. I’ll get those screenshots for you but by now I have about six project versions from experimenting with different settings. In the version where my clip settings now match the project settings all of the edited content within each clip is shifted temporally; the timeline becomes 4 minutes and 10 seconds, instead of 5 minutes exactly, perhaps because it is unable to re-insert those extra 4.97 frames a second for some reason. I know in Premiere one can copy work over to another timeline with other settings, and here in Shotcut I was hoping (fingers crossed) that there might be a quick fix for this.

There are a couple of video elements in the timeline that have other frame rates, but these oddballs were added later, the majority of the clips are 29.97 (will upload screenshot) … I think originally I must have imported an audio clip before any video, and in a rush to start the project I did not set things up right. Perhaps if I remove everything that is not 29.97 it will bounce back. Thanks again.


Here it demonstrates the properties of my main clips. … For the Master Properties it reads 25fps, but my timeline is intact at 5 minutes.

You might have a variable frame rate source video.
2019-09-10_12-09-22

You could try to use “Convert to Edit-friendly”
shotcut_2019-09-10_12-11-44
2019-09-10_12-12-01

Another way to change the frame rate of an existing project is to edit the MLT XML in a text editor (anything other than Notepad on Windows or Text Edit on macOS). Look for the <profile> element near the top and within that line change frame_rate_num and frame_rate_den. Of course, you need to re-open the project in Shotcut if it was already opened.