Changing video mode fps affects playlist video duration

Windows 10 x64, Shotcut 24.02.29
Steps: new project, add some videos in playlist, change video mode to double/half fps, double click on playlist items to see the “new” duration/out point

Just noticed that after changing video mode from 1080p59.94 to 1080p29.97 all my playlist videos (various fps and resolutions) have an “out” point set to the middle of the video.

Playing around, also did a test changing 29.97 to 59.94 and all videos in playlist appear to have double the duration (but of course the second half does not exist so it’s just the last frame repeated).

The Duration value in playlist and properties pannel also don’t agree anymore, except when both are wrong after the change.

I reproduced this. I do not know of a work-around.

There are actually several different ways to do this. How are you doing it? That may affect whether the length property gets saved as a bare integer (frames) or time clock value.

Here are the steps I use:

  1. Open Shotcut
  2. Click on the “Open” button.
  3. In the file dialog, select multiple files and click “Open” - this causes Shotcut to open multiple files in the playlist.
  4. Change the video mode to double or half the frame rate
  5. Sometimes I need to click in the playlist to cause the view to refresh
  6. Observe that the duration has changed in the duration column of the playlist

If it is helpful, I can do a “save as” after step #3 and I can confirm that the XML file contains time (not frames) in the playlist entries.

In my case I drag&dropped the .mp4 files into the playlist. I can see the issue both with only a single file dragged in playlist and with multiple dragged at the same time (originally about 50 files at the same time were dragged from the explorer window).

They’re a mix of videos from the gopro and phone, 29.97. 59.94 and 29.xx (variable). Video mode was manually set to 1080p29.97 before adding videos (so not automatic). Everything that’s already in playlist seems to be affected.

Going from 30 to 60 fps seems to be the most consistent at cutting the video length in half. The other way sometimes doesn’t show any problem, sometimes it does.

Probably irrelevant but originally I saw this problem with GPU effects enabled, I then reproduced without GPU effects on new empty project.

How can I fix the effects of this bug? I have been going through the videos for half of the day and adding slices to the playlist, and this bug messed up all my work…

For me I manually went through all the playlist and added them to the timeline manually selecting the proper slices. I don’t think there’s any fix for now.

I just made a fix for this for the next version 24.06

1 Like