Changing the bit depth and sample rate in Windows renders the player unresponsive in v18.06.02 and later. v18.03.06 and earlier don't have this problem

Steps to reproduce:

  1. Launch Shotcut.
  2. Open a video with some audio or audio file.
  3. Sounds start to play. Let them play.
  4. Click Windows button in the taskbar, click Control Panel, and click Sound.
  5. In the Playback tab, click a audio device that is checked as default.
  6. Click Properties.
  7. The Properties dialog appears.
  8. Click the Advanced tab.
  9. In the Default Format area, choose a bit depth and sample rate that is different from the currently selected.
  10. Click OK.
  11. The player in Shotcut stops responding.

This problem also occurs when I click Disable all enhancements in the Enhancements tab in the Properties dialog.

Tested on 18.08.14, 18.07.02, and 18.06.02, and all of them exhibit the same problem.
In 18.05.08, Shotcut hangs after these steps.
18.03.06 and earlier doesn’t exhibit this problem.

The resulting outcome in 11) is the same as the problem in this thread:

But there is no guarantee that fixing this problem will fix the problem in that thread.

Moreover, this problem is much more urgent to be solved because a lot more people are likely to encouter this problem because they must be using headhones, earphones, external speakers, or internal speakers on monitors to listen to audio.

a) Only tested in Windows 7 SP1 64bit
b) This happens on both two PCs of mine with different CPUs.

This is fixed for next release v18.09.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.