changing from "linear" to "smooth" for zooming on a video clip+

I’m new to Shotcut. I already like it a lot. I understand that to make a smooth zoom on a video clip I must highlight the desired clip; click filters; click video; click size, position, rotate; then click the keyframe logo. All that works OK for me. My Shotcut is preset for “linear”. To get to “smooth” I’m supposed to right click on the red triangle (diamond) in the extra channel below the highlighted video clip and that is supposed to allow me to change from linear to smooth. My problem is two-fold. The red triangle almost never appears. Even when the red triangle appears, it doesn’t display the option to choose smooth. Help! What do I need to do to get the red triangle (diamond) to appear and when it does appear what do I need to do to get the option to choose “smooth” rather than “linear”? Frank

You need to have two keyframes so that Shotcut has something to move to. Add a keyframe where you want the zoom to start (maybe that is the first frame of the clip, or maybe somewhere else). Then, add a keyframe where you want the zoom to stop (maybe that is the end of the clip, or somewhere else. Then, right click on the first keyframe and choose “To next” and then choose the curve type you want.

image