Changed "Display Settings" to "Automatic," now the window has parts cutoff

I changed my “Display Settings” to “Automatic” and now I can’t access the top bar that has file, edit, settings, etc

Sorry but we can not fix this incompatibility with that Display mode on your machine. You need to change the registry opengl key or run the installer and choose the option to remove all Shotcut settings from the registry.
https://shotcut.org/notes/configuration/