Change the UI font to one with fixed width (monospaced)

I’ve just started to use Shotcut, and I’m settling in well with it. For my use so far it has the right blend of power and accuracy with a clear interface that I have been able to learn my way around quickly.

There’s one little thing that I’d like to change in the UI, which is the font used for (one of) the QT widgets, the timer and frame counter that shows playhead position. The font that I am seeing in my install has variable width numbers, so as the frame count runs the other digits in the counter tremble sideways as the width of the two digit frame counter changes with most updates.

I’d prefer this counter to use a fixed width font so that the unchanged digits don’t move.

I can’t find a way to make this change in the menus or the config files. Presumably the font is set somewhere in Qt. Is there any way for me as a user to change this, say to my system font which has fixed width digits? (I’m using Fedora 37 Workstation.)

PS I’m fine with command lines and configs, but not a skilled programmer.

This is set to a monospace font on mac for this same reason due to its default system font. The font Qt chooses comes from the OS settings, and it cannot be changed at runtime as far as I know. I will change this for the next version to use monospace for all OS.

Thank you for a quick and helpful response. I can live with it for now!

I’ll also look at the system font settings on my install, just in case I’m somehow feeding the wrong font data to Qt…


Well, a quick comparison with a Shotcut install running on Linux Mint showed that they use a default system font (Ubuntu) with monospaced digits. So the counter behaves well.

So back on the Fedora system I checked the system font, it’s Cantarell which apparently is Fedora’s system font of choice but doesn’t have monospaced digits. Changing the font over to Ubuntu gives me a stable counter as in Mint.

So, for others experiencing this little annoyance, the following terminal command should sort things out:

gsettings set org.gnome.desktop.interface font-name ‘Ubuntu 11’


This is offered in good faith, I can’t take responsibility if it eats your homework. There may be a gui tool in Fedora to set system font, but I haven’t found it.

1 Like

Here is how it looks in Fedora 38, it don’t use monospace font

In Fedora you need the gnome-tveaks tool to change the system font

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.