Can't split the screen (overlay/composite doesn't work)

Hello guys, I’m trying to create a “split screen” video using two clips. I’ve followed this tutorial but the results are different from that example.

I’ve used the “Crop” + “Size and position” filter on both the clips to place the first on the left and the other one on the right side of the screen.
Even if I enabled the “composite” flag, the result is that only one clip is visible (the first one on top of the timeline), while the other clip (on the other side) remains black.
It seems that Shotcut doesn’t combine/merge the two clips. Can you help me to figure out why?

Is it something related to the hardware? I’ve an “old” HD4850 GPU and I’ve tried both OpenGL and DirectX video methods but no luck.

Windows 10, Shotcut is at its latest version (17.05) Let me know if you need more info or screens, thank you!

Forgive me if this is a silly question, but you have each video on a separate track, right?

Yes they are, I can provide some screens in few hours

Here is the situation:

The two tracks should be both visible due to the “Size and Position” filter (see the settings on the left)… but only the top one is visible while the lower does not appear.

If I hide the top layer (the clip on the right), the left clip appears.

Hi, try to disable the composite option of the lower track, usualy V1.

Already tried, doesn’t work

Try selecting the hidden track then in the preview window drag it into view.

Sorry, can you explain this? I did not quite understand…

Anyway, if you need them, these are the properties of the clips I used (same format, same size)

No, that is of no consequence.

Select the track which is not showing, then in the preview window grab the selection centre point and drag it to the other side.
The track may be underneath, this happens to me when I attempt a split-screen view.

I ended up deleting the project and recreating it again… I don’t know what was broken, but with a new project the clips finally overlap.

any other tips guys- my top cropped video appears but none of the other cropped videos. I’ve tried properties > blend > none.

Any help really appreciated