Can't run any Shotcut versions anymore - segmentation faults

What is your operating system?
Ubuntu 22.04.4 LTS
6.5.0-27-generic #28~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Mar 15 10:51:06 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

What is your Shotcut version (see Help > About Shotcut)?
Multiple versions:

  • 23.09.29 AppImage
  • 24.01.28 AppImage
  • 24.02.29 AppImage
  • 24.02.29 Snap
  • 24.02.29 Portable tar

I have libjack0 installed too.

Can you repeat the problem? If so, what are the steps?
I’m no longer able to run Shotcut - all of the above versions crash. Startup banner appears a couple of seconds, then exits. I’ve successfully used all of the AppImages above; I last edited my current project 10 days ago. But now none of them work; they just output the formats, audio, and video code lists, then exit with exit code 1.

I get a single journal log entry:

gnome-shell[1319]: Window manager warning: Invalid WM_TRANSIENT_FOR window 0x2a00008 specified for 0x2a00006.

I’ve tried looking around; I’m on X11:

$> echo $XDG_SESSION_TYPE x11

AppImages will coredump, but the others don’t. I have no debug symbols, but the backtrace for 24.01.28 AppImage is:

#0 0x0000796bbe044ce2 in ?? () #1 0x0000648f713881c0 in ?? () #2 0x0000000000000000 in ?? ()

There’s nothing useful-looking in ~/.local/share/Meltytech/Shotcut/shotcut-log.txt - all Debug/Info, then a couple of warnings about missing and DeckLink drivers not installed.

Strace log is huge (185k lines) - nothing obviously wrong near the end:

getpid() = 135218 poll([{fd=3, events=0}], 1, 0) = 0 (Timeout) poll([{fd=3, events=0}], 1, 0) = 0 (Timeout) poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}]) writev(3, [{iov_base="N\0\4\0\24\0\240\2\323\1\0\0'\0\0\0\1\30\f\0\25\0\240\2\323\1\0\0\0\0\0\0"..., iov_len=88}, {iov_base=NULL, iov_len=0}, {iov_base="", iov_len=0}], 3) = 88 futex(0x7fff0eb2ba28, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, NULL, FUTEX_BITSET_MATCH_ANY) = 0 futex(0x56ac517b2498, FUTEX_WAKE_PRIVATE, 1) = 0 exit_group(1) = ? +++ exited with 1 +++

Unsure where to go from here - I can’t interpret the backtrace without debug symbols. I’m trying to build it from scripts/ but looks like that needs hand-holding as it keeps failing on repo’s that use main instead of master.

Aside from that…the apt log shows the following package updates since Shotcut last worked:
libuuid1:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libuuid1:i386 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
uuid-dev:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
rfkill:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
xserver-xorg-core:amd64 (2:21.1.4-2ubuntu1.7~22.04.9, 2:21.1.4-2ubuntu1.7~22.04.10)
xserver-common:amd64 (2:21.1.4-2ubuntu1.7~22.04.9, 2:21.1.4-2ubuntu1.7~22.04.10)
libfdisk1:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
xserver-xorg-legacy:amd64 (2:21.1.4-2ubuntu1.7~22.04.9, 2:21.1.4-2ubuntu1.7~22.04.10)
mount:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libmount-dev:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libmount1:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libmount1:i386 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libsmartcols1:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libnspr4:amd64 (2:4.32-3build1, 2:4.35-0ubuntu0.22.04.1)
libblkid-dev:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libblkid1:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libblkid1:i386 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
xserver-xephyr:amd64 (2:21.1.4-2ubuntu1.7~22.04.9, 2:21.1.4-2ubuntu1.7~22.04.10)
util-linux:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
bsdutils:amd64 (1:2.37.2-4ubuntu3.3, 1:2.37.2-4ubuntu3.4)
bsdextrautils:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
libnss3:amd64 (2:3.68.2-0ubuntu1.2, 2:3.98-0ubuntu0.22.04.1)
fdisk:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
eject:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
uuid-runtime:amd64 (2.37.2-4ubuntu3.3, 2.37.2-4ubuntu3.4)
xwayland:amd64 (2:22.1.1-1ubuntu0.12, 2:22.1.1-1ubuntu0.13)
google-chrome-stable:amd64 (123.0.6312.105-1, 123.0.6312.122-1)
libnss3:amd64 (2:3.98-0ubuntu0.22.04.1, 2:3.98-0ubuntu0.22.04.2)
libgnutls30:amd64 (3.7.3-4ubuntu1.4, 3.7.3-4ubuntu1.5)
libgnutls30:i386 (3.7.3-4ubuntu1.4, 3.7.3-4ubuntu1.5)
gir1.2-javascriptcoregtk-4.0:amd64 (2.42.5-0ubuntu0.22.04.2, 2.44.0-0ubuntu0.22.04.1)
gir1.2-webkit2-4.0:amd64 (2.42.5-0ubuntu0.22.04.2, 2.44.0-0ubuntu0.22.04.1)
libjavascriptcoregtk-4.0-18:amd64 (2.42.5-0ubuntu0.22.04.2, 2.44.0-0ubuntu0.22.04.1)
libwebkit2gtk-4.0-37:amd64 (2.42.5-0ubuntu0.22.04.2, 2.44.0-0ubuntu0.22.04.1)
klibc-utils:amd64 (2.0.10-4, 2.0.10-4ubuntu0.1)
libklibc:amd64 (2.0.10-4, 2.0.10-4ubuntu0.1)
libnode72:amd64 (12.22.9~dfsg-1ubuntu3.4, 12.22.9~dfsg-1ubuntu3.5)
nodejs:amd64 (12.22.9~dfsg-1ubuntu3.4, 12.22.9~dfsg-1ubuntu3.5)
libnode-dev:amd64 (12.22.9~dfsg-1ubuntu3.4, 12.22.9~dfsg-1ubuntu3.5)
nodejs-doc:amd64 (12.22.9~dfsg-1ubuntu3.4, 12.22.9~dfsg-1ubuntu3.5)

libwpebackend-fdo-1.0-1:amd64 (1.14.2-0ubuntu0.22.04.1)
libwpe-1.0-1:amd64 (1.14.0-0ubuntu0.22.04.1)

I haven’t made any other notable changes to my system in that time.
Any suggestions? Bit lost where to go here…

Thanks in advance – rob

I guess it looks like the fast multi threading locks have changed from 16 bit values to 32 bit values and it crashes by an inappropriate 32 bit access on an non 32 bit alignment address. It does not help you, I know.

The best thing would be if you try to compile Shotcut on your system to solve the problem.

You also can try to use an older klibc-utils and an older libklibc version if futex is the problem and it is located in one of this standard libraries. This theoretically can be relinked with patchelf and checked with ldd and libtree.

Note, that I do not know how to fix this problem but maybe I could help you my thoughts.

Sorry to hear that, and we run that build script in automated daily builds on a Ubuntu 20.04 docker image. Seems you tried allot of things, and I’m not sure what else to try. I recommend to use the flatpak. FYI, portable, AppImage, and Snap are the exact same builds, but not Flatpak which is the most confined.

No worries. Thanks anyway - and thanks for the advice about the Flatpak, that works fine :+1:

1 Like