Can't play exported videos

I’ve created a couple of videos and saved them to my computer as MP4s, but when I try to play them in windows media player I get a message saying the file can’t be played because ‘the player might not support the file type or might not support the codec that was used to compress the file’. This is really frustrating: what is the solution?

What settings did you use to encode your clips?
Keep in mind that MP4 is only a wrapper for the audio and video, the codec inside can be many different ones, most of which Windows Media Player does not support.

Try the default H.264 with AAC audio in a MP4.

This happens all the time for me. Try renaming the file with .mp4 at the end and try to play it again.

I just left it on default as I don’t understand all the settings. However, H.264 is not showing up as an option. The default seems to be libx264

Tried that, still not working…

well is h264_amf or h264_nvenc showing up? if not then try re-installing shotcut or just export in a different format all together.

Make sure you have the latest version of Shotcut here: Shotcut - Download

If you saved the project, it saves to the an MLT file (XML coded language). This is not your video, but more of a set of instructions telling Shotcut what your project is.

Click the export icon to open up the export panel.

Uncheck “Use hardware encoder”

If you don’t understand the different settings then don’t go into advanced.
Don’t worry about presets either, the default is an mp4.
Simply press Export File. shotcut_2019-03-04_12-18-46
Name your file. (Best practice: Ensure you have .mp4 on the end of the file name)

I would ignore Windows Media Player, and just use VLC Media Player. VLC is much more advanced than WMP.

No, only h263 or h263p. I’ve already reinstalled it once. I don’t know anything about formats so when you say, ‘just export in a different format’, what do you suggest?

I can’t see an option to uncheck hardware encoder. Can’t actually see file name and save as type either. Here’s what my export panel looks like: Capture

More than likely you’re not running the latest version, which is 19.02.28 (Help-About Shotcut)
But if you got into advanced and changed a bunch of setting around you can reset them them by click on “Default” in the Presets selection.
These are the “Default” settings.
The developers have worked very hard so that anyone could export video without knowing anything about advanced export options. Going into advanced could lead to a bad export if the wrong settings are selected.

Well, I’ve been exporting to 4k res, so my resolution settings are different in that aspect.

Maybe avi, webm or flv

Thanks for all the suggestions, but I didn’t change any of the presets and I’ve now downloaded the latest version, as well as VLC. I still can’t play any of the videos I’ve made, either in media player or VLC. I’m at my wits end here - spent a long time on a couple of projects and now they’re essentially useless unless I can figure out why they won’t play. Any other ideas?

There isn’t must more to help out with unless you share specifics about your video project and/or your computer.

What steps would someone have to through to duplicate the issue?

I don’t know how one could duplicate the issue. I’m a beginner so just imported some clips and played around with them - I didn’t change any of the presets. I’ve now exported it as H.264 and now the audio is playing in media player and VLC, but not the video.

Either your computer is not compatible with Shotcut and/or something in your project is causing this issue. Again, without sharing specifics, I’m not quite sure how others can attempt to help you. Maybe others can chime in with advice. Good luck with your project.

This video was exported and uploaded last night.
For me, exporting with no preset selected, this is what I get.

Hello:You can share more data from those videos that you can not play.

-One method is using VLC. In the “Tools” tab you will find “Codec information”. of the file that you can not play.
-You can also use the “Mediainfo” software to see (and share here) the data related to those videos. MediaInfo shows more data from the video file.
You can find Mediainfo here:


You can also see the properties of the video file created in Shotcut.
For this, you can import the video to Shotcut. Select the clip and click on “Properties” in the upper general menu.
A coupled window will appear, with the Video audio and metadata values. Also if you click on the burger button you will access, (among other options): “More information”
You can also run the “File integrity check” that will generate a record with data that you can share here.
Surely someone can help you if you provide more specific data.

I was using this thread earlier in the day trying to solve this issue, and none of the solutions worked. I finally tried some combination of things that worked, and I’m pretty sure the key was canceling out of the dialogue box that appears when you first add a new clip to work on. I had been going ahead and converting the clip to an easy-to-edit format as that dialogue suggests before. Try using the default settings for exporting and just not letting this conversion happen at the beginning.

1 Like

Hi i was facing the same problem, but finally found a solution, i did the following-
Click export
Click advanced tab at the bottom of export box.
Directly under “From timeline” check the box for “use hardware encoder”, shotcut searched the computer and changed codec from libx264 to “h264_qsv”
I didn’t change any other setting and exported, for the first time my video could play.
Hope this helps, i guess based on the manufacturer company of the laptop, encoding might differ, i was using a laptop by Dell