Cant open video on portable SC

Hi all,

i installed SC (20.07.11) on an older desktop PC with Windows Vista OS.
I used the portable version and just copied it to C:programms.
SC opens fine but i cant draw any video (h.264, mp4) into the playlist or timeline.
Same with file–open… Always get the message “Cant open…”

Am i missing something with the portable version?

Maybe the problem is the PC is missing codecs or driver? I didn’t do much updates since first OS installation, guess it was around 2006 :worried:
I can play all video files with the VLC player and Magix Video de luxe tough.
How could i just update missing codecs and alike?
Any hints appreciated!


Need Windows 7 - 10

1 Like

Thanks Hudson - would have to upgrade this but i better dont touch a running system :slight_smile:
I left the old PC untouched and it still starts as fast as on the first day. The more updates and Support Packages you install, the slower your PC will be.
I just used it for Photoshop (up to PS-CS4) and 3d-Rendering with Cinema 4d (up to Rel.13) und Video editing (Magix Video de Luxe - some old version). So codecs must be there somehow.
It is 64bit but Windows Vista. SC starts fine - just can’t read the video files. I would guess i need some driver or video codecs? What exactly is the limiting factor?

Shotcut does not use external codecs. It uses ffmpeg which is compiled into it and also bundled as an .exe for conversion tasks. Shotcut is fully self-contained.

More likely, Shotcut or ffmpeg is making an unsupported file system API call on Vista, then trapping and reporting the error as a generic “cannot open file” message.

1 Like

I might try an older version of shotcut, something from the 2016 or 2017 stands a better version of running on vista(vista support ended in 2017 from msft) I’d also run windows update, there was a platform update in 2009 that backported a lot of win7 components into vista(perhaps enough for SC20 to work)

1 Like

Thank you - will give it a try!
Interesting that the old versions zip-file is more than double the size of the new one?!
Normally the newer versions get bigger and bigger, cause functionality and features are growing.

Some things have been phased out over time, there’s some filters I know are depreciated.

1 Like

Just tried the old version win64_170402. When i try to start SC i get the error message:
“Der Prozedureinsprungpunkt “GetActiveProcessorCount” wurde in der DLL “KERNEL32.dll” nicht gefunden”.

english: "the procedure jump point “GetActiveProcessorCount” wasn’t found in “KERNEL32.dll”

Hmm - thats the 64bit version and i put it into 64bit-Programs, don’t know we he looks into Kernel32?
Seems there’s something missing.

Also tried it in the x86-programs folder but same error. Seems there is no procedure like that.
Any ideas?

Well, that could be a graphics driver problem, it might also be worth jumping back another year or two to say a 2015 version @shotcut could say for certain when vista stopped being supported I’m unfortunately guessing. It may be worth updating your graphics driver(if you can) and checking for that platform update I mentioned as well.

The old versions included around 250 MB of graphics files that could be used as transitions. Those were removed in later builds.

This is OS level, as in Win32 API. It has nothing to do with graphics or drivers. It means Shotcut is trying to call a function in the OS that exists in Windows 7 and above but not in Vista.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.