Can't find %luma22.pgm loading .mlt

I tried to resume a project by opening the associated .mlt and got the message “Can’t find %luma22.pgm”. A file name that begins with % is generally bad news. There is C:/Program Files/Shotcut/share/mlt/lumas/NTSC/luma22.pgm but didn’t fix the complaint.

It’s possible (likely??) that the .mlt was created by the rev. prior to 17.10.2. I updated to that rev. last night. And that may have broken things. Or not.

I’m going to file this note as a help/how-to, too.

Now I’m really confused. I did a version check from the Shotcut workspace, and got a message to do an update. Which I did. The current about… says I have 17.10.2 and that’s the only rev. I can find in the download area. Am I being delusional here?

ADDED: I was delusional.

Redundant - deleted.

I recreated the clip that, when saved and restored, results in the %luma22.pgm message. It worked as it should. I saved the project, tried to open it and… %luma22.pgm error message again. This is, from save to open, over a span of 10-15 seconds.

The clip opens with a 3 second audio and video fade-in. BTDT a lot. No problems with .mlt’s. There is one transition. Instead of a dissolve, it’s a clock wipe. That’s something I haven’t worked with before. I made the planned cuts and transition, left it as a dissolve, saved the project to a .mlt. Closed Shotcut, opened it, opened the .mlt and all is well.

I then changed the dissolve to a clock wipe, saved it, closed and opened Shotcut, opened the .mlt and… shazam %luma.pgm error. It appears that using the clock wipe (nothing else was touched) caused the problem. But wait - there’s more!

By accident, I hit OK instead of cancel on the %luma22 message and… 1) it went away, 2) the workspace screen went away, and 3) the correct project, complete with clock wipe, showed up as if nothing happened. [/active headscratching]

All of this is under Win10 patched to date. Ditto for Shotcut.

The % is intentional and instructs the engine to locate this particular file on disk where it was installed. That said, there is code in the XML missing files checker to try to skip this sort of file name, and I am not reproducing on Shotcut 17.10 for Windows. In the XML it should say <property name="resource">%luma22.pgm</property> and nothing before the %. Does yours have any leading path? Do you have steps to reproduce it from a non-existing project?

I’ll dig into this and report back.

FWIW, the project is on an external HDD that is moved between the Win10 machine and a Linux machine. I assume that a .mlt file created under Win10 is effectively meaningless to the Ubuntu instance of Shotcut and vice versa. The drive keeps the same I:/ every time it’s connected to the Win10 machine.

Shotcut will write MLT XML with relative paths to assets that are in the same folder or a subfolder of the XML file. So, projects can be portable to a large degree if you follow this simple guideline and copy or move files to accommodate (preferably before including them).

Much to my amazement, the error is repeatable. Not all .mlts have this problem. If I click OK, the project loads as expected.

The error message lists the correct pathway to the sub-directory containing the .mlt.

This is how the message appears.

This is the .mlt causing the error.


From looking at your MLT XML file, the key thing to reproduce this bug is to enable GPU Processing. I fixed this for the next release 17.11.

Wow! I’m glad I can contribute to the cause.

What do I need to do to create the problem under Ubuntu 17.10? I might as well see if I can get the same message there, too.

Or will your 17.11 address the issue under Linux as well as Win10 and Macs?

All platforms were affected the same and fixed in the same manner.

Gotit. ETA for the update?