Can't export to Ogg, exit code 1

whenever I try to export to an ogg file I keep getting the same error, I know ogg is a bit of an odd file type, but I need it as one. Anyways here’s the log:

[libx264 @ 0000026e387d9300] using SAR=1/1

[libx264 @ 0000026e387d9300] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2

[h264 @ 0000026e387d72c0] Reinit context to 1920x1088, pix_fmt: yuv420p

[libx264 @ 0000026e387d9300] profile High, level 4.0, 4:2:0, 8-bit

[aac @ 0000026e38cda6c0] Too many bits 8192.000000 > 6144 per frame requested, clamping to max

[h264 @ 0000026e38f0bd00] Reinit context to 1920x1088, pix_fmt: yuv420p

[h264 @ 0000026e52c400c0] Reinit context to 1920x1088, pix_fmt: yuv420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 0000026e388095c0] Statistics: 228754 bytes read, 0 seeks

[chain avformat-novalidate] C:/Users/[My name]/Downloads/yVoxSxoufEJp.mp4

checking VFR: pkt.duration 1024

[filter swresample] 2(stereo) f32le 44100Hz → 1(mono) f32le 48000Hz

[h264 @ 0000026e38c96040] Reinit context to 1920x1088, pix_fmt: yuv420p

[ogg @ 0000026e3880e8c0] Unsupported codec id in stream 0

[consumer avformat] Could not write header ‘E:/Music library/fish.ogg’

[aac @ 0000026e38cda6c0] Qavg: nan

[AVIOContext @ 0000026e3e26e400] Statistics: 0 bytes written, 0 seeks, 0 writeouts

Failed with exit code 1

Are you using Advanced export settings to attempt this? A screenshot of your settings would be useful.

What I can see right off is that AAC audio cannot go into an Ogg container. The audio codec needs to be Vorbis or Opus or FLAC. Also make sure that Disable Video is checked. Ogg is primarily an audio-only format these days. The main video formats supported are Dirac and Daala, which have minimal usage.

To add to what Austin wrote, Ogg cannot contain H.264 either (see libx264 messages). WebM (see our presets) has mainly replaced Ogg Theora+Vorbis, but if you really need Ogg Theora+Vorbis you can; try this: start by choosing the Ogg Vorbis preset. Then, go to Encode > Advanced > Codec and turn off the checkbox Disable video and set Codec to libtheora.

This topic was automatically closed after 90 days. New replies are no longer allowed.