Can't change export settings for a MLT imported as clip


I tried the following:

  • Created a new Project
  • Imported an already existing MLT as a clip (Clip is 1920x1080 in native resolution)
  • Added this clip to the Timeline
  • Opened the export tab and changed the export resolution of the clip to 1280x720.
  • Export

So far no problems but the exported video is in its native resolution of 1920x1080.
I tried this serveral times with various clips and it seems that this behaviour only occur if a MLT project is added to the timeline.

OS: Windows 10 64 Bit
Shotcut Version: 17.05.03


let me trow a brain rush out for you did you try manually edit the mlt file? dunno if it works but try btw do backup first!

Same here.
I just tried to repeat the problem as you have explained. Not having an issue exporting at a lower resolution than the .MLT indicates. The .MLT is just telling Shotcut where the source file is and what edits you have performed, it has little to nothing to do with choices made for exporting,

Just tried it. I changed the project tag because this was the only place where I could find the resolution. Seems nothing has changed.

[quote=“Steve_Ledger, post:3, topic:1583”]
I just tried to repeat the problem as you have explained. Not having an issue exporting at a lower resolution than the .MLT indicates.[/quote]
Strange. Then most certainly I’m doing something really dumb.
I just have it repeated, same result. I attach the project files, export log and the export xml to this post. Hopefully you will see what I’m doing wrong.
clip.mlt is the one which is included by test.mlt

clip.mlt (3.5 KB)
export-mlt.txt (3.1 KB)
export-log.txt (2.6 KB)
test.mlt (2.5 KB)

No, those files don’t help me at all.

try this, make a custom export profile with 1280x720, then set project as 1280x720 and try exporting

thats the only thing i can think of

Nope, did a fresh uninstall/install and did as you mentioned. Still same result. This were the parameters for the export profile:

To be doubly certain, I just tried again.
No problems, the exported result conforms to the export settings I choose and not the original resolution of the clip source whether that is larger or smaller. I get what I export at.

So my settings are;
Shotcut video mode is set to 'Automatic’
I drag’n’drop a saved project file (.mlt) to the playlist (one where the original source was 1920x1080)
Then drag the clip to the time line
When I’m ready to export, I select one of my custom export profiles, eg: 1280x720 / 30fps / MP4 / libx264
Press the Export button, choose a file name and location…done

Result is exactly what I wanted.
So Unless I witnessed your full workflow, I have no idea what’s different for you.

Almost. I open the saved project via File->Open MLT XML As Clip… And drag and drop from the player window to the timeline.

I tried it your way, and it works!
Thank you very much, this gave me some headache.

Ok, I think I was just a little to euphoric. In fact when I drag’n drop a saved MLT to the timeline Shotcut opens this MLT instead of adding it to the current project.

Open the .mlt first

Yeah, found it. Have to edit of the active mlt otherwise Shotcut will simply open the one dropped over it.

It seems everything goes fine even with the “File->Open MLT XML As Clip” dialog if there is a already a (real) clip in the playlist of the project. But if I add only a MLT File I come to this problem.

Thank you again! Problem is solved for me. I can now work around this behaviour.