Can't change duration of a slide

I cannot change the duration of a slide. I tried typing over the hh:mm:ss, using the arrow, etc, but it keeps changing back to the default of all the other slides.
And, of course, if I change it to the default, then all the other slides change too, which is not what I want.
I also tried stretching in the timeline, but that keeps crashing the program in Windows 10 (64 bit).

You need to press enter while field had focus. I can drag right edge to change duration in the timeline without crash on Windows 10. Maybe Shotcut is not working well on your system.

No Dan, she and the others who reported this are correct, I too was just going to write an entry (as question, not as bug report), then thanks to the great popup saw that this has been reported numerous times already.
So yes, even with “You need to press enter while field had focus” the duration change does NOT apply, for me neither. I tried

  • per arrow keys
  • per entering the new value
  • with return after enter
  • with clicking elsewhere after enter
  • with clicking back into the photo in the timeline after enter
  • with clicking on the next photo after enter

Nothing worked.
Nor worked what another poster wrote “set as default”. My shotcut (newest v) just always goes back to 4sec instantly.

With that said, I am aware I COULD go about splitting each image, but do that with 12…

This reminds me that I had two related suggestions, now is the time to post them, just in case you like them?

  1. Selecting the entire track, then clicking Properties, only comes up with Blend mode.
    Wouldn’t it be cool to change more properties for the entire track? Eg, duration of each clip on that track, etc? I think yes would be.

  2. With footage in the timeline (not photos), changing Speed does get applied correctly, both to the clip and the change in duration accordingly.
    But again, when changing Duration, it does not get applied. Again tried the whole lot of hitting enter etc, like above.

Wouldn’t it be cool if Shotcut could handle both, since it shows both?

  • allowing to change Speed (this works, and duration is correctly calculated)
  • and allowing to change to a specific duration, and Shotcut would calculate the speed for it, and apply the change.

Not filed anything as bug reports, as your post suggests that on your system you CAN change duration, both of photos and footage in the timeline. But the other posts here in addition to mine suggest that many people can not?

Anyway, LOVE shotcut still. Amazing program, I can’t believe you make it free without watermarking. Just like the guy of Blender does. Awesome! Thank you!!

Shotcut Version 18.07.02

I changed the duration here with the red dot, then put it in the timeline (V1).

I changed the duration here with the red dot, the put in the timeline (V2).

In the Source tab, drag where the red dot is at.

This is a bit extreme, but 2 hours, 30 minutes, and 48 seconds long for an image.

An the final result after dragging from Source to Timeline.

And on the timeline itself. On the right side, drag left or right, it will show you the difference from where you started and the final length in the blue outlined numbers. Note: You do need to have the playhead somewhere to the left of where you’re dragging or you can use the playhead to align where you want it to stop. Usually when you place the image in the timeline, the playhead will be to the right, just move it over the center then drag to desired length.

To change the duration you have to change the time (where it’s highlighted in blue) and click where I have the red dot. As you hit enter where the value is at, it changes the value just above where it says Source. This screen shot was taken before hitting enter.

I closed and reloaded Shotcut, opening a different image, and it loads to 15 seconds automatically.

What you write is correct but it distracts the sw owners from what I wrote, which is correct too.
I think the source is a slight misunderstanding?
What you are doing here is, you test if shotcut remembers your set default value AFTER “I closed and reloaded Shotcut” as you wrote.
So yes, maybe “default” is not meant to apply as default to every clip in the ACTIVE project (like anyone understands it) but to the sw itself when closed and reopened (default as in properties, so to say). I appreciate this new meaning of “default” that you clarified, thanks.

Regardless, I just tried an a fresh/new project, and no, shotcut current v, does NOT change duration. In fact, hitting return once does nothing, hitting return a second time changes the value entered back to 4sec.

For me, like for the others, there is absolutely no way to change the duration of a clip of the active project (other than splitting the clip in the timeline like I suggested as the only workaround, but undoable for many clips). All my other improvement suggestions hold true as well. I trust you agree, because you didn’t mention.

What does work is what you wrote: set new default duration, close shotcut, reopen it, and then ALL clips got the new duration.
But that’s hardly what any user would/will be doing. Right?
We work on the ACTIVE project.
Also we need to set individual durations for different clips in the timeline.

Finally, try this: Highlight a clip in the timeline,
click Properties
change the duration
see what happens :slight_smile:

So yeah, it does not work with duration, there is a bug, or at least sth that isn’t what users will expect how it works. I think it’s fair to say that users expect it to work like I described at the top?

Oh forgot to say: I like what you eat, very healthy :slight_smile:

No, I proved to you that it works after closing it. I don’t test Shotcut, I’m a user of Shotcut. I only provided this images and steps to help you.

As far as I know there has not been any poll to find out, but I’ve changed the duration of clips all of the ways I’ve shown, and I’ve shown a few others in here too, and it’s worked for them.

In this picture, I’ve set the duration default before opening another picture. As the picture loaded, it loaded to the last default I had set. No project saved, no restarting.

The properties window is for changing the length before you drag it to the timeline.

Once it’s in the timeline, you can only change it on the timeline using this method:

At this point, with Shotcut Version 18.07.02, using Windows 10 Home, changing the times works flawlessly for me.

I’m suspecting your version didn’t install correctly. I would suggest uninstalling and reinstalling with the option to clear your registry settings. If that doesn’t clear things up, I do suggest sharing your computer specification, operating system, and Shotcut version number. I hope you get this resolved soon.

No, it’s not fair to say. You’re not speaking on my behalf or for others who love this software. What’s described at the top of this post is asking how to change the duration. People can, in here, do express major expectations of Shotcut, but unless one learns how to use Shotcut for how it does actually performs, it’s just wasted energy. Shotcut is very powerful and the devs are very interested in what people want. To have a free video editor on virtually any platform, with constant updates/developments is priceless.

OK, that does not work by design. You cannot use the Duration field to change the duration of an image already in the Timeline. That is because there is no way to force constraints that occur when using the timeline such as a clip to the right of the image that should not be overwritten. You must use the keyboard shortcuts ‘I’ or ‘O’ (only to shorten) or drag the trim handle on either end of the image clip. If there is stuff to the right of the image on the timeline that you want to shift when dragging, then enable the toolbar option “Ripple trim and drop”.
I will make a change to disable the Duration field for an image in the timeline for the next version.