Cannot resize video

I have used shotcut before without problems but am now working on a vid synced to music with greenscreening and masks anyway for me it took a while. The camera I am using puts out 1280x720 25fps. I noticed when I started importing clips that they showed up in the viewing area quite small so I just zoom fitted everything 50% so it didn’t seem like a big deal. Now when I export, or upload to youtube, the video is very small, taking up perhaps 3 inches x 2 inches (landscape) in the middle of a 6 inches x 3 inches (portrait) black background. I have not been able to change this with every imaginable export format/resolution/codec. Funny thing is, whatever changes I have made to shotcut while doing this, if I start a new project and import the same video it exports in full size format just fine so I guess whatever changes I have made to shotcut since when I started the project must have changed something. However after playing with this for a while I have realized that the mlt files do not contain any video, they simply reference the original video, which is still there in 1280x720 format, so it would seem that there must be something I can do to retroactively get the video I have been working on to show in full screen format. I have even tried cutting everything but the first few seconds of the first clip, and then adding new clips, but this still results in all the clips in small format. What do I need to do? Thanks in advance.

Hello and welcome @philq,

always remember:
Before importing images or films, be sure that your ‘Videomode’ in the settings-menu are equal to your filmdata (size and fps).

This situation looks very similar to the following thread and a solution is posted there:

EDIT: Scratch that. Your situation sounds a little different, sorry. But if you are familiar with text editors, you could compare two .MLT files side-by-side and see what’s different about them. By any chance, is there a Rotate and Scale filter applied to the track head of the track you’re dropping videos onto? Any filters on the V1/V2/V3/etc track heads will apply to all clips on the track.

DvS - thanks I will not make the mistake again of proceeding before I have checked that I am getting the output I orientation and size I want. However now I want to go back and fix my mistake.

Austin - I did not realize the MLT files could be read with an editor …thanks…is there a guide to reading the various commands? I think now that the problem is the vid I created before this one was in portrait and at the time I specifically set up a custom video mode to scale everything properly, but when I started this vid I had not used shotcut for a long time and did not remember to change the portrait to landscape, so now it is trying to shoehorn a landscape shot into a portrait ‘window’. Is there a MLT command that reflects what I did when I set up the custom video mode initially? Thanks

In the MLT XML, edit the <profile> tag near the top of the file. Change width, height, display_aspect_num same as width, display_aspect_den same as height, sample_aspect_num=1, and sample_aspect_den=1. You then need to revisit all filters in the UI to ensure things are layed out as you like.

Thanks for the tip but doesn’t seem to make any difference?? In fact no changes seem to make any difference, I even put in a line of total nonsense characters and I got no errors just the same tiny landscape inside a portrait black box???

<?xml version="1.0" encoding="UTF-8"?> 00:02:08:03 pause d:/Users/phil/Videos/Metalfish/MVI_0513_pulses.MOV ..............
<?xml version="1.0" encoding="UTF-8"?> 00:02:08:03 pause d:/Users/phil/Videos/Metalfish/MVI_0513_pulses.MOV

ok the forum seems to be cutting off the rest of the code I was pasting in there???