Cannot rename tracks in v18.03


Under Linux, I cannot rename tracks (V1, V2, A1, A2)
I did rename those tracks with a text editor, opening my project.

What happens under Shotcut :
I can select V1, V2, or A1, A2,
but Shotcut shortcuts are used instead of text input !
for example, if I press the space bar afterV1, it plays the video… instead of inserting a space.
Same behaviour with other letters.

I tried entering text with Ctrl, Alt keys pressed -> it does not work.

What could I check ?

Same thing’s happening in Windows. Tracks cannot be renamed.
Might want to categorize this thread as bug.

This is a regression in the latest version where fixing one bug resulted in a new one. :frowning:

Problem solved with Shotcut-git from Aur (archlinux)
I can rename tracks with V18.01.02 !
This version also enables html overlay filter

Not in version 18.03.02. It’s still a problem.

He is using a build made by someone else against a different version of Qt that is more well-behaved. I had to make a little bit of an ugly workaround for Qt 5.6 that Shotcut is using:

I already started working on an upgrade to Qt 5.9.2, but a couple of builds are not yet working. Work in progress.

I understood that he’s using a different build. But I renamed tracks in V 18.01.02.

And I did this today in the Linux version of 18.01.02.


There was no problem renaming tracks in the previous version of SC.

That was a typo on his part. He meant to write 18.03.0? (depending on date of build) based on Git master.

Got it.


I can rename tracks with V18.01.02 !

Not with versions above.

Fixed in version 18.03.06.

Using Shotcut 18.09.16 (Qt 5.6.1) under Kunbuntu Linux 18.04

Last week I did a project and renamed all of my my tracks with ease.
Today I started a new project, and I cannot rename the tracks.

As a test, I reloaded the project from last week. Now I cannot rename tracks in that project either.


The mysterious user interface.