Cannot export 4K video

I have installed fresh Shotcut.
Made a test clip and try to export it following the instructions I have found on the net.
It goes to the jobs and after few seconds fail! Time and again!
How should I solve this problem?

You need to look at the export job’s log. You might need to turn off hardware encoder if you turned that on. See the #FAQ

What is the hardware encoder?
How do I turn it On or Off?
I did not make any changes to the default after the fresh installation…

This is a rude and not friendly reply one expects in a forum where people share a common interest and sometimes when needed assist each other!
BTW, it is a new PC with freshly installed Windows 10.


Sorry MusicalBox, follow your advice - no luck - just keep failing

How much hard disk space do you have? can you show a screenshot ?

Are you using 4K video from your camera? what type of camera?

When you say ‘Settings from the Internet’ what settings?

Please show what settings.

Since I just bought a 4k camera and have never tried this, I just took the opportunity to try it myself on my windows system.

Works fine as far as I’m concerned.

Available disk space - 214GB
Camera - DJI Osmo Action

Keep failing to export…

It seems to be a fairly new and modern camera. So I’m starting to think that it might be a CODEC issue.

What recording mode do you have the camera set to ? to create the 4K files ? Is it by any chance 60fps because there are reports of problems with that framerate.

Have you tried with normal 1080p footage ? Getting that working first.

Perhaps this is a DJI issue ? because I can find other DJI users having the same problems.

I’d also try checking that you have upgraded to the latest firmware.

i am using in my DJI 4K 60 FPS. no problem to view them and no problem and no problem at all to work on them with both VSDC, Open Shot and Filmora! I wanted to try Shotcut, but I am about to give up.
My DJI is just super fine with the latest firmware.

In the second post, Dan asked for the export log. I haven’t seen one provided yet.

Try to do an export again. When it fails, go to the Jobs panel, right-click the failed job, and look at the log. Send it to us here. Without that, all we can do is make wild guesses.

If you see video at all in the Shotcut preview window, then there is no codec issue involved.

1 Like

Oh well, that pretty well confirms that it’s a Codec issue of one sort or another.

You may expect that every Editing Software out there should support your video-camera but that is not often the way

For example, I have a JVC video camera where I have to run a conversion on the video with FFMPEG before I can use it in any Windows editing software. The same thing exists for youtube-dl video files. They all need conversion and pre-processing.

For example, this is what I need to do to pre-process my JVC videos:

write-host “Converting your file to mp4 to”, $outputfile

ffmpeg -fflags +genpts -i '$inputfile' -r 24 '$outputfile'

I think the same is needed for these DJI cameras because the codecs obviously don’t match up perfectly.

It’s probably the responsibility of the said camera owners to work out how to do it rather than expecting people without the hardware or media files to do it.

Not necessarily. There’s the possibility of things going wrong when every frame in the input stream is read and passed through the output pipeline. Codecs can be quite complicated.

It’s really hard to speculate without any logs, proper screenshots or sample video files.

I CAN see video at all in the Shotcut preview window…

Without the export log to tell us anything for sure, all I can do is offer one last speculation. Perhaps the exported video is going to a Windows Protected Folder, which will fail for permissions reasons:

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.