Cannot create proxies for videos

I’m not sure if this is just me for some reason (wouldn’t be the first time) but when I try and make a proxy, I get the below error in the log:

[hevc_nvenc @ 00000138a224fb40] Loaded Nvenc version 12.1
[hevc_nvenc @ 00000138a224fb40] Nvenc initialized successfully
[hevc_nvenc @ 00000138a224fb40] 2 CUDA capable devices found
[hevc_nvenc @ 00000138a224fb40] [ GPU #0 - < NVIDIA GeForce RTX 2080 Ti > has Compute SM 7.5 ]
[hevc_nvenc @ 00000138a224fb40] supports NVENC
[hevc_nvenc @ 00000138a224fb40] InitializeEncoder failed: invalid param (8): Gop Length should be greater than number of B frames + 1
[hevc_nvenc @ 00000138a224fb40] Nvenc unloaded
[vost#0:0/hevc_nvenc @ 00000138a2250b80] Error while opening encoder - maybe incorrect parameters such as bit_rate, rate, width or height.
Error while filtering: Invalid argument

I was able to before on 231129 (I uninstalled and reinstalled), but on 231215 I keep getting this issue. I also notice I can’t just drag and drop a video file in the playlist anymore but not sure if this is related.

Anyone else seeing this or know if I’m just missing something?


(And yes I disabled my AV and even ran shotcut as admin)

Turn off hardware for proxy in Settings.

1 Like

Yea that worked! I didn’t think to change that since I know it worked in the previous version as I tested it (multiple reinstalls). Oh well, I’ll just let them process for a while as I’ve already spent too much time on it.


Ha! I just RTFM on your post about proxies and I was just hitting my head against a wall anyways by assuming using the GPU would have even benefitted me (assuming this still holds true for the current versions). Though a bit old now, my CPU can easily handle it. Hopefully others will see this and not repost the same question! → Proxy Editing

I reproduce it. It broke with the FFmpeg upgrade. I fixed it for the next version 24.01.


This topic was automatically closed after 90 days. New replies are no longer allowed.