Cannot change speed of clip since upgrading version


#1

Hello, I upgraded to version 18.12.23 the other day.
I’m on MAC OS High Sierra 10.13.6.

Today I tried changing the speed of a clip via Properties, and when I press Enter or click out of the input field, then the selected clip becomes deselected and the speed of the clip does not change.

This persists even after rebooting my computer and restarting the application. So yes, I did try turning it off and on again. :wink:

I have my Shotcut in English, but it still shows a comma instead of a period in the speed properties field. This has never been an issue for me in the past, but I mention it because I saw that it was once an issue in older versions of Shotcut when trying to change the speed of clips.

I hope I’m just overlooking something and that it’s not a bug. Can anyone advise? Thanks in advance.


#2

The numeric format is taken from the operating system and independent of Settings > Language. Why do you think it is showing a comma? What is your Language & Region set to in System Settings. If you have changed the Number Separators in Advanced to be inconsistent with your Language and Region, then it might have a problem. I am not able to reproduce the problem on same versions using English.


#3

Hi,
In Shotcut I see this:


I’ve checked my settings in the computer and they look like this:

(My system language setting is in English, region Belgium.)
When I change the number separator “decimal” from comma to period, then the number separator in Shotcut does not change (even after reboot).
I will try uninstalling and reinstalling the application after changing the setting to see if the number separator in Shotcut updates to period instead of comma and if the issue is resolved.
I’ve never had a problem changing clip speeds in the past, and I have always had the comma as a number separator in Shotcut, so if this doesn’t work, then maybe it’s unrelated to the number separator?
Will update with results in a bit.


#4

I’m still seeing a comma as the decimal separator in Shotcut after uninstall + reinstall (but again, I’m not sure that this is causing the problem), and I am still unable to change the speed of clips (which is the actual problem).

Here’s the steps I took exactly:

  1. Uninstall Shotcut.
  2. Change decimal separator to “.” instead of “,” in system settings.
  3. Reboot computer.
  4. Reinstall Shotcut.
  5. Open existing project and select clip in timeline --> comma still visible, can’t change clip speed.
  6. Open new project and drag a clip into timeline --> comma still visible, can’t change clip speed.

To try adjusting the clip speed, I tried both the numeric steppers and keyboard inputs.
I also tried clicking the focus out of the field to apply the change, as well as pressing enter.

Any ideas for what I can try next?
Thanks!


#5

Not a Mac user, but maybe this article can help: https://9to5mac.com/2018/08/09/mac-how-to-change-language-and-region/ Perhaps you’ve already been through these settings.

On Windows while just having the cursor over the speed, I can scroll wheel up/down. If I just click anywhere within the field box, PgUp/PgDn + - 1 sec. Up Arrow/Down Arrow + - .1 sec.

After I do scroll + - the value, I have to click inside the field box, then push enter or click anywhere outside the field box.

This is where you can find your language settings in Shotcut.
shotcut_2019-01-10_09-17-33 shotcut_2019-01-10_09-17-57


#6

Thanks for the input. My system language is English, as is the language setting in Shotcut.
Again, I’ve only started having this issue since updating to the latest version of the app; and I’ve never changed around my system settings before running into this problem, so at this point I think it’s maybe unrelated to the decimal separator. That just seemed to me like the most logical place to start.


#7

This is the problem, and I reproduced it. Shotcut does not work good when the language’s numeric format and region’s numeric format are different. This is a long-standing known problem. You keep talking about upgrading, but you did not state your previous version. I went to v18.03 for comparison. Yes, in that version Speed works, but Size and Position is broken. In version 18.12, Size and Position now works but not Speed. Again, the Language choice in Shotcut does not make a difference as that only selects a UI translation.
You can workaround this and verify by making your System Language and Region agree. In the meantime, this bug remains open, and I will see if there is something I can do.


#8

Hi, I’m not sure of my previous version. I didn’t make a note of it before I installed the latest version.
Both speed and size and position worked fine in the previous version I was running.
I’ve just changed my region to USA in my system settings, which resolves the issue. It’s not an ideal workaround, seeing as how I am not in the USA and it’s much more convenient for me to have my computer set up for the region I’m actually in, which is Belgium.
What does it mean precisely to make my system language and region “agree”?


#9

Just for fun, I changed my region back to Belgium and system language to Dutch (one of the 3 or 4 languages that I would expect to “agree” with the region), and when doing that I could speed up a clip but not slow it down. Every time I tried to slow down a clip, Shotcut would crash. Just thought it might be interesting information for when the speed issue gets addressed.
Thanks for looking into it; I can get my thing done now that I have a workaround.


#10

I fixed this for the speed when the region and language have different decimal separators for the next version 19.01 !!

I did not reproduce your crash when slowing down, but that is another open bug that is tracked on Github:


#11

Whoa, that was FAST. :smiley:
Thanks again!