Can Shotcut Incoporate K-Lite Codec Pack for H.264/265/Av1 Playback and Editing

I have an old laptop with 16GB RAM, 1 TB nvme SSD and an Intel i5-6300U processor that has 2 cores\4-threads, a base clock of 2.4Ghz and automatically boosts to around 2.9Ghz. This laptop is from 2018 so its fairly new still. I can playback any kind of 4k H.264/H.265 video using K-Lite codec pack and it barely uses around 6-11% of the CPU depending on the clip. My question is why can’t Shotcut utilize the K-Lite codec pack and media player classic for 4k video playback during editing so that its not choppy frame by frame editing? Can Shotcut allow users to use a different media player during editing if that’s easier?

Yes I know H.264/265/av1 is designed for compression and playback not editing. I’ve read all the forum complaints on 4k editing on Shotcut, Da Vinci Resolve, Premiere, etc. Can’t the developers of Shotcut and the developers of K-Lite codec pack get together and make a baby so that I can edit 4k H.264/265/av1 videos properly? It can’t be really that hard can it and I can’t be the first one to think of this?

I want to avoid proxy files, transcoding, etc which eats up more time. For some reason using proxy files downgrading to 360p resolution is still choppy. I can’t transcode to DNxHD or some other less compressed format. It says failed.

For reference select the mega pack instead of the standard.

Are you using Proxy by itself or together with Preview Scaling?

I am using both the preview scaling and proxy files but its still choppy. Encoding is fine as the CPU has Intel Quicksync. Just the editing just choppy. no filters or any effects applied yet. Just combining clips together into a bigger clip and trying to chop bits I don’t want included.

When you say “its still choppy” do you mean there is no improvement? Also, how long are your projects?

Yes no improvements. After stringing multiple clips together they are 7-35 mins long but performance is the same aka terrible regardless of clip length.

More info:

These clips are native DJI Osmo Pocket clips with 3840x2160, 8-bit,100Mbps data bandwidth, compressed in the H.264 format which the Osmo pocket does in real time.

Example 1m:18sec clip
Video: MPEG4 Video (H264) 3840x2160 29.97fps 99910kbps [V: DJI.AVC [eng] (h264 high L5.1, yuv420p, 3840x2160, 99910 kb/s)]
Audio: AAC 48000Hz stereo 189kbps [A: DJI.AAC [eng] (aac lc, 48000 Hz, stereo, 189 kb/s)]

Media Play Classic:

The answer is: “Because no one has volunteered to do that work.”. Also, it would not be trivial because the Shotcut software architecture is designed to depend on the FFmpeg API.

Have you tried different display modes in Shotcut? If you search the forum for “choppy” and “lag”, you can find many ways to improve the playback performance (as @DRM has been prompting as well).

Our volunteer developers have a rough roadmap for continually improving playback performance over time. One thing we are looking into is higher utilization of GPU resources for effects. But this will be a long road because there are way more feature requests than volunteers.

Thank you for the reply and I am grateful for this tool that you have provided. I am no developer so I don’t know the difficulties of combining those two open-source products. Early versions of K-Lite also used FFMPEG and probably still includes it.

I have scoured the forums and google for performance playback improvement tricks to no avail. Going to try an diagnose why I can’t trancode to a less-compressed format shortly.

What are your video mode settings? (Click on Master/Output then click on Properties)

Staying in the Properties window, click on your DJI clip, what does Shotcut display about your clip?

This is the clip first imported into Shotcut. No filters, effects added. No modifications whatsoever and playback is choppy. Output on exporting file is set to H264_QSV. UHD +MP4 container + AAC audio.


Don’t know what it was but

  1. Uninstalled Shotcut
  2. Delete All Shotcut folders in C:\Program Files
  3. Search for any traces of Shotcut in registry and deleted
  4. Restart Laptop
  5. Re-downloaded + Re-intsalled Shotcut
  6. Set Proxy On + Preview scaling to 360p
  7. Shotcut starts transcoding clip to H264 360p
  8. Restart Shotcut because it warns you to after turning on proxy
  9. Proxy preview clip now plays smoothly
  10. Can’t avoid a bit of wasted time transcoding but this is it or a get a new laptop.
  11. YAY! I can wait to buy that 128GB RAM, 128-core/256-thread AMD Mobile Ryzen 5900H CPU + Nvidia RTX 3090 video chip laptop.

Shotcut is the best editor ever now. I’d say Shotcut is better than Resolve for beginners and lite-users as it incorporates hardware encoding at no cost. The free version of Resolve only has software encoding. You have to pony up $300 to get Resolve Studio that gives you hardware encoding and additional collaboration ability.

Thanks all for your responses and help.


So if all other feature requests were put on the backburner to instead focus everything on developing GPU utilization, theoretically how long would it take to get done?

Is anything ever really “done”? :slight_smile:

Dan and I hope to start exploring GPU options by the end of this year. I would guess that it will be a year before it is usable for many tasks. It’s all just a guess, though.

1 Like

When you start adding tracks & effects, no doubt things will get choppy again. Whenever that starts to get out of hand I’ll mix some tracks down into a single (or a very few) tracks, if possible. That effectively bakes in any effects and flattens multiple tracks into one. Then the processing resources are freed back up.

Flat out rejected and closing this.