Can not export. Help please!

I am trying to export to .mp4 several .mlt files (which were edited from .AVI ) files. Each time I get ‘Failed’. When I had the same problem some months back, someone helpfully advised me to change the target directory - and this worked and has always worked since, on the few occasions the problem re-occurred, This time - no luck. The files are simple, no ‘extras’ added (like audio track or titles). Thanks for any help - RJ99 (enthusiastic ShotCut user).

Happy to paste the log message if it will help

Forgot to add

Shotcut 19.10.20
Win 10, 64bit, 16Gb

Right click on the job that failed and post the log that is displayed.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/AUTHORS’: “C:\Program Files\Shotcut\lib\ladspa\AUTHORS”: The specified module could not be found.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/COPYING’: “C:\Program Files\Shotcut\lib\ladspa\COPYING”: The specified module could not be found.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/readme.txt’: “C:\Program Files\Shotcut\lib\ladspa\readme.txt”:

[libx264 @ 000000000b13c080] using SAR=1/1

[libx264 @ 000000000b13c080] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX

[libx264 @ 000000000b13c080] profile High, level 1.3, 4:2:0, 8-bit

[libx264 @ 000000000b13c080] 264 - core 157 r2945 72db437 - H.264/MPEG-4 AVC codec - Copyleft 2003-2018 - - options: cabac=1 ref=2 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=6 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=7 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=1 keyint=127 keyint_min=12 scenecut=40 intra_refresh=0 rc_lookahead=30 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00

[consumer avformat] Could not open ‘C:/Users/Main/Videos/1993-Mura Bustan-Han Party.mp4’

[aac @ 000000000b13d8c0] Qavg: nan

Failed with exit code 1

Is this your source video or the video you were trying to export. If it is the source video can you play it with another video player, like VLC?

It is the destination video. There is a problem with being able to write.

Thanks folks.

Elusien - the video has been on my HD for many years; I used ShotCut to edit it, then tried to export.

Leader - I tried two different destinations. Just tried two more (different drives); the ‘Failed’ appears almost instantly. Any suggestions what I can try next?

Shotuct first does a write test to that file and if not writable, it shows a dialog with the message

Unable to write file …
Perhaps you do not have permission.
Try again with a different folder.

Then, it removes the file, and the background program for export tries to open the same file for writing. I think something running on your system does not like that and is interfering. For example, is this drive/folder being synced to a cloud drive or backup system such that when it writes the temporary file it becomes locked for a short while? Or perhaps some anti-malware is preventing this.

I assume you’re logged in as user “Main” and not trying to write to another user’s folder? Doing so would produce a similar permissions error.

Solved, thanks everyone for the tips. Tried again this morning, exporting this time to an external SSD … successfully, all the files are now merrily exporting perfectly and rapidly. Great, I’m taking the opportunity of Lockdown to dig up those family movies from the mid '80s onwards to clean 'em up and convert to MP4s - ShotCut is perfect - made even more perfect by the existence of this superb Forum group. Appreciated! :slight_smile:

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.