Can i use gifs?

hi all
not sure if im the only one with this problem but everytime when i try to use gif image for video timeline …program crash

did i do something wrong or shotcut didnt support gifs ?

No, you’re not the only one.
I once tried to use an animated gif.
Put it as part of the playlist and SC showed some outrageous duration length and dragging it
onto the timelime caused problems.

Since animated gifs are not a top priority for me, I gave up and just convert them to mp4 first if I need to use one.

Yes, you can, and someone else reported here:

Note that neither of you have specified an OS, version, or the GIF. I tested version 19.04.30 on Windows and macOS. If your GIF is animated, it should not even permit it because it loads as an unseekable clip that Shotcut blocks dragging to the Timeline. A non-animated GIF works for me as an image clip. By default (unless you suppressed it) Shotcut detects a non-seekable clip and shows a conversion dialog. In case you suppressed it, or it does not show this dilaog, you need to use the Convert to Edit-friendly… function in the menu button in Properties.

Shotcut tries to discourage users from adding a non-seekable clip to the Playlist or Timeline, but there is a workaround by adding it to the Playlist by clicking + or using Shift+A… Using + prompts you for a duration to prevent the problem you experienced. I just found that the keyboard shortcut does not. Since FFmpeg treats the animated GIF as loopable, it does not determine a duration, and the Shotcut engine interprets this as a live source with a duration of INT_MAX frames. I will have to add that dialog to the Playlist keyboard shortcuts. In the meantime, use + to get a duration prompt.

Just tried it on Win 8.1 and not only does it import it onto the playlist, it shows something like 38,260 hours, 55 minutes, 24 seconds and a handful of frames for the duration.
In fact SC crashed so badly, it completely froze the machine and I had to reboot.
However not surprised considering it’s windows.

SC version is 19.04.30

How are you importing it? There is nothing in Playlist or Shotcut UI that says “import”.
I just found 2 other ways to bypass the duration dialog: drag-n-drop from a file manager or Recent.

Dragging it onto the playlist from the file manager.
Here is the gif I used. (191.0 KB)

I reproduce it now using my own animated GIF.

OK thanks for the confirmation.
For me it’s not a big deal to have animated gif support as I actually prefer to first convert externally to mp4 (or mov if I need alpha) and then all my assets are in a video format and at 25 fps.

I know many on this forum use ShareX so I guess for them having animated gif support may be rather important and convenient.

This is fixed for v19.07 due in July.
Meanwhile, to fix your current project, remove all GIFs from the Playlist. Add your GIF by double-clicking it in Recent or using File > Open… At this point you may be prompted to convert it, which is going to fail in v19.06 due to a bug. That bug is fixed in the new version 19.06.15 available tomorrow. Or, today, with the current version, you can cancel the dialog and press + at the bottom of Playlist to add it. Clicking + will prompt you for a duration. It is not too important to set a correct duration because you can increase it when you add it to the Timeline by dragging the end of the clip.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.