Camera low depth field - glare effect disappear when overlaying 2 video clips

Need help … probably due to my lack of knowledge of camera “effects” and how to overcome in SC.

I have made a clip of “stars” flowing and set my camera depth to low value … to get this “glaring effects”. It is save with transparent background.

It was fine on its own on v2 (picture 1)
But when I try to overlay with another video clips, the glare effect simply go away. (picture 2)
I tried to play around the “chroma key”:advance … it did somewhat get back the glare but a little messy. (picture 3)
Any help/advise what filters to use to resolve this ? or ideas ?
Picture 1:

Picture 2:

Picture 3:

Hi … thought maybe I put a picture of what I like to really achieve
see picture below.

I could achieve somewhat using Blender … 2nd part of picture but Blender is not design for long video editing. So what I really hope is to use SC to achieve this result on the bottom part of the picture or something close to it will suffice. I suspect is something to do we color background of my V2 clip that perhaps need to be lighter instead of Alpha (Transparent) and using chroma advance filter to tweak it somehow but afraid I am going the wrong way … perhaps there’s a better way that someone can advise me. Thanks in advance.

Why is your ‘Blend-Mode’ off???
Set it on and try different settings, e.g. Subtract, Multiply…
You’ll not need Chroma-Key if your source is transparent.

Hi @DvS,
Yes I tried all options in Blend. Does not give the “glare” effect … that was why I turn it off and try the “Chroma Advance”. You are probably right that no Chroma-key needed as the source V2 is transparent (alpha).
Hmm still can’t figure out how to solve this.
Picture shows I used Blend = Screen this example … “stars” lost its glare

Same source clip … stars has its glare effect when not overlaying.


I upload the “stars” video source file in case someone have the time to take a look and see if this transparent file can be tested out.

Hmm can’t upload the video file … even I zip it down to 500KB

If the star video was recorded by a camera, how did the transparency channel get added? Looking at the second screenshot, it appears that the transparency channel is strictly on/off instead of gradual levels of transparency.

Ah I forgot to mention that I used Blender 2.8 tool.
When I said “camera” I am referring to the Blender tool’s camera.
Alpha channel is “rendered” with Blender tool setting …

It works fine within Blender environment but when I get the alpha rendered output and use SC… this “glare effect” which is a “compository” setup just does not appear I mentioned above when overlay with another video … on its own, it is ok in SC.

I use Blender to render this animation within Blender env. with the “said video (on V1)” to demonstrate the effects works only in Blender env. I am trying to investigate further why … perhaps I thought has to do with how SC fllter works? but I could be wrong as I am not familiar with “alpha channel” behaviour in SC.


Found the problem … it is on Blender itself.
Appears the “rendering>Bloom” output in alpha channel in png file uses premultiplied alpha.
The PNG image specification does not support these kinds of images with additive glow. When Blender writes a PNG image, it is discarded.

Alternative go back to Blender to “enhance” the “Glare” node to glow specifically in alpha channel.

So can drop this topic now.
Thanks for those attempt to assist.
using SC to get this to work now.

wrong clip … corrected with this one with “stars” blinking this time on alpha channel.

This topic was automatically closed after 90 days. New replies are no longer allowed.