[BUG] Overlaping soundtracks

I was creating a project, and for now i’ve been using Shotcut like a lot for small project, but it’s probably like the first time i overlap two soundtrack to create the “fade” effect, just like i do with videos track.

While it works fine with a “video + audio” track overlapping each other
Overlaping 2 soundtracks from the same video file, I can never export the project.

I am using files from Nvidia, recording with 2 separate tracks.
Mount the video on a video track, detach pist audio 1 (default one), then go to properties and do the same (detach audio track, wich is now the second track, btw, quite a pain in the ass, it should better create as much audio track as there are on the video file)

This tool produces videos with variable frame rate, which is not supported. Nevertheless, I made a video with this capture tool with 2 audio tracks. I added the clip to the timeline, detach audio, go back to video clip’s properties, change audio track from none to 2, and detach that. This exports fine for me. I am unable to reproduce it.

The issue is not detaching two audio tracks from one source, it’s to detach them AND to overlap them (to create a fade effect)

like this : shotcut_7OmAu1UxSv
(the part on the right is still the same file)

this type of project will always fail to export.
There is another message just above, asking me the project file, i’ll upload it there, if maybe you want to look at it too.

(because of the rules here for new members, i’ll have to create multiples message, in order to reply correctly)

to add some infos, when i delete the part where i overlap soundtracks, it exports, if i let them, it fails.

The Project :
StarCitizen3.8.1-letoren_en_action.mlt (163.0 KB)

Properties:


2 audio tracks (2 ch 48Khz aac)

It’s not related to the file itself, it’s the way different track from one source is managed (my guess).
I am converting a Nvidia file right now, selecting “better” as the option, using latest shotcut version available at this day.

annnnd it’s still buged : shotcut_IFR7bvPtCf

the issue comes from Shotcut, not the source.

(If an admin can edit my messages to be one, like it was intended to be, thanks in advance.)

OK, I reproduced this bug. The issue reproduces when “overlapping” means making transitions on the audio tracks. That was not clear to me before. I will look into it.

What the actual F ?
Delete your post, your personnal opinion does not matter, nor your message is in any way useful to the topic.

This is spam.

2 Likes

Thank you and sorry for the bad explanation.

Should i do something with the topic now ?

Per your request.
Best of luck to you. :slight_smile:

I am sure he deleted his posts as no longer relevant since the bug was accepted. That is not spam. There is nothing for you to do but wait for a fix. I have bookmarked this, but it may not be fixed in time for the next release. The simplest workaround at this point is to remove one of the transitions in one of the audio tracks.

This is fixed for the next version 20.02 due in a little over a week.

Just perfect, thank you for both taking your time in here and on the project.
Have a good day ! :slight_smile: