Bug? Order by which video filters are applied


#1

Hi All,
Imagine I need to slightly rotate a video, say 0.5 deg., and then crop so to keep only a central part in the picture.

If I rotate only, I see black triangles being added to the sides, that is ok, as it is needed so that the final geometry is the 16:9 rectangular.

Then I crop even to a very small part of the video… but I still see the triangles!

I first thought that the issue was due to the order I applied the filters in. I need to rotate first and crop second, and that is the order by which the filters are listed top to bottom, but I still have the issue.

Any suggestion? I’m using Shotcut 18.3.2 on Linux. Thanks!

Giacecco


#2

The result that you probably want is most easily accomplished by increasing the “Scale” setting on the Rotate filter, which will increase the size of the source file so that the black triangles aren’t seen. So, with just the one filter, you get it all – no need to worry about filter order.

However, regarding filter order:
It looks like the Crop filter will crop the source file, no matter where it is in the filter order. What you want in this situation is the Mask filter. This will give you a black border, no more black triangles.

  1. Rotate (possibly with “scale” applied")
  2. Mask (“write on clear” – may need something underneath it in the mix to work properly)
  3. Size & Position (ONLY if you’re trying to do something that Rotate’s “scale” isn’t able to do, like change the horizontal/vertical location of the clip)