Bug is back : Crackling at start of audio in exported video

Operating system : Windows 10
Shotcut version : shotcut-win64-210129

So I am using shotcut for one week now and pretty happy with it. Very intuitive and powerful.
I use it for a repetitive task : add audio track to soundless videos.

Puzzling thing : The source video cannot be responsible for the hiss as it is soundless and audio tracks are shifted to play a couple of seconds after the video starts so they cannot be responsible for the hisses either.

Steps :

  1. create project
  2. insert and populate 1 track for short video without audio
  3. insert and populate tracks for 4 different audio (soprano, alto, tenor, bass)
  4. mute all audio tracks except soprano. Export soprano video
  5. mute all audio tracks except alto. Export alto video
  6. mute all audio tracks except tenor. Export alto tenor
  7. mute all audio tracks except bass. Export alto bass

On some of these produced videos I have a high pitch crack/hiss noise at start up. Exactly what is described by Rick1 in October 2019 under title "Crackling at start of audio in exported video"

As this bug was marked fixed and closed, I downloaded version v19.12.16 and tried it.
And yes, I don’t have that issue anymore.
So version 19.12.16 solves my problem and does exactly what I need but I still thought I would submit a bug report to help Shotcut programmers on their way to make the best free lightweight portable video editor in the world.

Extra information 1 : the crack/hiss is not the same on every produced video. Sometimes it is there, sometimes not. But if it appears on a video, reexporting the project will result in the very same disturbing noise at startup. Removing 1 or 2 ms from the start of the (soundless) video sometimes allow to eliminate the issue. But sometimes not. Also what’s confusing is that the noise is not played by VLC. But when I upload the video to Archive[.]org then I can hear the noise. During my investigations, I found that Avidemux plays the hiss and also an online tool like video-cutter can play it. It is even better to use audio-cutter since you can also see the artefact.

Extra information 2 : I prepared a self-contained testcase with a .mlt file and corresponding video + audio files but when it came to uploading it, the 8Mb zip file was refused for being too large. I keep it on my computer for you if you need it one day.

Can you provide sample audio for people to test with the current version of Shotcut?
Can you show a copy of your timeline as well?
What is the Video Mode?
What is the Audio channels set to?
What are your export settings?

Since you have not gave any details about your audio file, do you think this same post could be related to what you’re experiencing?

Hello Hudson555x

thanks for your help.

It took me ages but I succeeded to create a small test case for the current version of Shotcut.
PopAtStartUp-TestCase.zip (3.3 MB)
In the archive is a file called Configuration.png which should answer your questions.
I also added an exported video file that contains the pop at startup (VideoOutput 03-Tenor.mp4)

Steps to reproduce the issue :

  1. Open the project
  2. In the Export panel,
  • go to Video tab and set Frames/sec to 10
  • go to Codec tab and set Codec to h264_amf
  • go to Audio tab and set sample rate to 12000Hz
  1. Export all the files
  • First export Soprano video
  • In the timeline, mute Soprano and unmute Alto. Export Alto video
  • In the timeline, mute Alto and unmute Tenor. Export Tenor video
  • In the timeline, mute Tenor and unmute Bass. Export Bass video

At least one of the produced file should have a pop at startup. In my case it was Tenor
Surprisingly enough, if I quit and restart Shotcut between exporting each video I don’t have the issue anymore. Also if I don’t export all 4 videos I don’t get the issue either. It is kind of weird.

Hi! I can confirm the initial exported crack with Shotcut 22.04.25 on Linux, using the default settings plus the following changes:

Source: a video recorded with Zoom
Export video settings: mp4 at 8, 9, or 10 fps
Export audio settings: aac mono 22050Hz average 32kbps

The problem with a mono audio source was also reported here:

In many cases, this problem is caused by clips that have a variable frame rate. Check the frame rate of your source clips and make sure it is a “standard” frame rate. If it is not, your clip might be variable rate. You can view the frame rate in the properties panel.

If a particular clip is giving problems, It is a good practice to convert the clip to to an “edit friendly” format. You can do that by clicking on the “Convert…” button in the properties panel.

It is generally not a good practice to change the frame rate in the export settings. This feature has only very specific uses when the export frame rate is changed to some multiple/factor of the Video Mode frame rate. For best results, change your Video Mode frame rate to the desired rate and let the export rate follow the Video Mode rate. If you want an odd frame rate (like 8fps), you can create a custom video mode.

Hi brian.

The frame rate of Zoom recorded videos is 25.000000. I do not know whether it is standard or not, but it seems it is not variable. I did several tests following your advice, and these are the most remarkable results:

  1. I used a generated “edit-friendly format” video, but it did not produce any difference. The crack was still generated in exportation.

  2. I used a new video mode (Settings > Video Mode > Custom > Add) preserving the resolution but reducing the frame rate from 25 to 10. Then I exported using the same settings than my previous post. The crack was not generated at the beginning of the resulting video! Wonderful!

I use very low quality settings (e.g. 10fps, quality 33%, 32kbps mono 22050Hz) to export screencast recorded lessons to the smallest readable video files, because my server space is reduced and some students have low bandwidth connections.

I am very thankful with your solution, brian!

1 Like

Having to reduce the frame rate from 25fps to 10 to overcome the issue does not sound “wonderful” to me