Blur effect creates black frame


#1

Hello!
First of all, thanks for a great video editing software!:relaxed:

I’ve noticed that when add blur on the corners appear black stripes, as I understand corners of the image, mixed with the black pixels. Is it possible, to make blur without making this strange effects?


#2

It would appear that the blur filter will give this “border” effect, whose width is approximately half that of the blur filter’s width or height size, presumably because it cannot get the “other” pixels that are outside the image.

You may be able to remove these artifacts by performing multiple blurs using masks, but it seems a lot of trouble to go to, or you may be able to crop the artifacts out.


#3

The simplest method I came up with to remove the artifacts is to add a 5% zoom Size and Position filter after the blur filter. It’s pretty effective up to a 30px blur. If the blur factor is higher you might try a 10% zoom.

5% zoom preset.

01 Blur Corrector 5%.txt (211 Bytes)

Also made a UI for the squareblur filter for SC but I cannot get it to work like it does in Kdenlive. Maybe you can do your magic and make it work?:smile:

squareblur.zip (2.4 KB)


#4

Is the modified version now working for you?


#5

No, it’s not really working like it does with KDL

KDL with filter set to 1/2 max.

KDL

SC at 1/2 max.

SC

Not a great difference but the blur is too much with SC.


#6

I see what you mean. Its strange, as both Shotcut and Kdenlive use MLT. I can’t think why it should be so, unless the guys over there have modified the actual frei0r code. All we are doing is producing the front-end to that code and I’d have thought that they would just do the same.


#7

Here’s the KDL front end for the filter.

frei0r_squareblur.zip (340 Bytes)

The KDL scale goes from 0 to 500. I’ve tried many different combinations but just can’t get it to work properly.
:confused:


#8

The frei0r squareblur filter has not changed in years.
https://github.com/dyne/frei0r/commits/master/src/filter/squareblur

As you can see the Kdenlive XML file limits the max of the frei0r parameter to 0.5 while you have set it to 1.0 for MLT.


#9

Guys, I am an ordinary user, I appreciate you pay attention to my request, effort and time that you put in this discussion :hearts:
I just want to know, is it possible in the nearest future to have unbordered blur effect in SC?


#10

As Sauron’s post (#3) above states - the “squareblur” filter does what you want.

You need to download this filter (unzip it) and put it in Shotcut’s ‘filters’ folder. Then restart Shotcut and you eill see the “squareblur” filter in the list of filters.

See this post for more information of where to put the filter:


#11

Made a slight modification to the squareblur filters UI. It works a bit better now.

Square blur.zip (2.4 KB)

This blur filter works much better than the squareblur filter. It’s keyframed as well.

IIR Blur.zip (2.4 KB)


#12

Thank you guys! :heart::heart::heart::heart::heart:

It’s amazing!

Sauron, IIR Blur is outstanding! Just what for I am looking for. Thank you again :hugs: