Blinking images on fade to opacity


#1

I have an image that begins to fade, blinks back into full opacity mode, then fades again. Anyone know what that’s all about and how to fix it please? I have another couple of images overlayed on top which function as intended. I tried deleting the problematic one, dragging again to the timeline and re-applying the filters, yet I get the same result.


#2

Can you provide us with more information? Maybe post a screenshot or export?


#3

I used to think I could export a segment of a movie with Shotcut, but now can’t find the option if it exists. I can’t export the entire video because it’s nearly 27 minutes long and the process dies at 77%.

Oh well, a pic will have to do.


#4

Use the Open MLT XML As Clip function.

image

Set the in and out points for the export and export the segment.


#5

So it’s the image in V6 that’s “blinking?”

Are there any clips in other tracks (V1-3)?

I’ve experienced something very similar but I hadn’t figured out exactly what was the cause; I do remember finding a workaround though.


#6

No, it’s Jaws that blinks on v4. Beneath this I’ve got a backing soundtrack and voiceover. No other visual stuff… well, not at this juncture anyway.


#7

Does Jaws/V4 blink back to full opacity right as the clip on V5 ends? (or at the same time that any changes occur with the soundtrack/voiceover?)


#8

Yep, it’s too fast to determine that when playing at normal speed, but if I watch frame by frame it’s right at that moment. As Jaws fades out we roll into a movie in a frame though I’ve tinkered with the beginning and end of the two clips without being able to make any impact so I don’t think that’s a factor.

Hopefully these oddities (they happen elsewhere too) don’t appear in the final render, just the preview. I can’t tell as I haven’t been able to produce one.


#9

If you’re saying there’s a clip fading in in V1 or V2 (I’m guessing V1!) I bet that clips in that track will mess with compositing throughout the project, as that was what I’ve experienced before. I had to just leave the track blank whenever there were clips in other tracks. Try moving the fading-in clip to V3.


#10

From memory, yes, I think that’s probably the case. The same element will be split across two tracks so as to present together, most likely v1 and v2.

Elsewhere I’ve got items that just disappear where they are set to fade smoothly. Some fade in OK then vanish abruptly, while others appear abruptly and disappear in the same way.

Interesting, that’s another thing to try thanks. I’ve read other people suggest inserting a blank track. If that could become v1 and shunt everything else upwards that would be a simple test, though I suspect it’s more likely to be v83 or whatever it is I’m up to now (slight exaggeration, maybe :D). I swear this video is going to be the basis for an upcoming nightmare.

It may seem daft to have so many tracks, but sometimes it’s the only way to ensure other elements on the same line don’t get out of sync when you edit an earlier segment, forcing you to re-apply all your changes. On a few occasions deleting an item has caused everything after it to move backwards rather than just leave a blank. If it’s possible to move something into its own space and then delete it, that seems to avoid the issue.


#11

Here’s the finished version (including timeline ref). It’s still not entirely smooth, but a lot less noticeable than it was originally.

Another oddity occurs here. You see how the background after the transition doesn’t relate to the actual ‘wallpaper’ that fades in afterwards? No idea how to fix that. I tried to play about with the start/end points a number of times, re-rendered and it’s still the same.


#12

I’ve seen that blinking problem on cross-fades when the Video mode in settings (specifically FPS) is not the same as in the actual video fragments. For example, if your project Video settings has 1920x1080 30 FPS but you use videos 1920x1080 24 FPS and do the cross fades or video fade in/out or similar with static images you may see this effect because the fade effects miscalculate the number of frames required for smooth fading. For me personally, I’ve seen this problem in almost all the releases I’ve used and I learned to always start from setting the Video mode exactly the same as the video clips in the project. Hope that should help.


#13

Thanks for the tips, I’ll keep that in mind. I can ensure the project settings match the source videos if I’m capturing all the footage myself and they come from the same device. Where it gets tricky is when you’re, say, discussing a selection of games/movies and the video comes from a number of different places, and they’ve been encoded in different ways. I suppose I could re-encode everything first to be uniform and then drag it all into Shotcut. That would be a useful experiment.