Blank screen on startup


#1

I am using Windows 7-64 with 8 GB of memory and the latest Shotcut. After installation, when I launch it, all I get is a blank white screen at the top left of which it says, “Untitled - Shortcut”. That’s it. No menu, no buttons, nothing. I did start it as Administrator, to no avail. Reinstalled it three times.Tries starting it in Compatibility Mode. To no avail. Any ideas? TIA.


#3

Rebooted your PC and tried?
Does 17.02 still work?
I always try the portable version of new releases first and so far 17.03 seems fine.


#4

I do not know if this is your problem, but for the benefit of Steve and others: on Windows, version 17.03 now defaults to DirectX for the Settings > Display Method. There are quite a few people we have helped to get Shotcut working by telling them to change it from Automatic (previous default) to DirectX. Therefore, I decided to try changing the default to try to make the shotcut defaults more compatible. The jury is still out on this. I recently received one problem report from a user unable to use DirectX and only OpenGL (go figure, AMD GPU). So, it may be very difficult to say which is better without collecting usage data over a period of time, which we do not do.

(A side benefit of the DirectX default is that mode does not make GPU processing available and people who want to try out that unstable, experimental mode will need to know to switch to OpenGL.)


#5

I downloaded the portable version of 17.03 and the display method is still OpenGL, I haven’t made any changes.
I have an AMD R7 360 GPU.


#6

First thing I do any time my PC misbehaves - reboot. :wink:


#7

Thanks to both of you, I will try it again tonight.


#8

If you had already changed your Settings > Display Method, the new default will not apply. The new default only applies to first time users or users who have not changed Display Method previously. Also, the portable version still uses the registry (or your app data directory if you have set it). For Shotcut, “portable” does not mean it will never touch your registry; it still does. And when you set an app data directory, it stores that selection in the registry. Perhaps not the purest form of “portable.” There is an exe “–appdata” option to set the app data dir without using the registry.


#9

FYI:
windows 7 32-bit, openGL, new install 170302 => blank screen at startup
uninstalled rebooted, 170302 portable => blank screen at startup
same for 170201-05
same for 150105
It’s an old machine so who knows what is conflicting with the install…
Fix: installed 170302 on windows 10 64-bit machine; works great, thx


#10

Did this work out in the end? Kind Regards.


#11

Hello Shotcut forum.
I have a problem similar or identical to the original poster, ie I get a “Shotcut Untitled” window which is white and blank within the border, showing no menu options etc.
I have a Windows 7 64 bit laptop, with 4gig of ram, 500mb hard drive, with Intel Pentium T4400 processor. The laptop is a Packard bell Easynote TJ65.
My first attempt was with Shotcut win 64 v180102. Reading this, and another forum entry on here, led me to experiment with older 64 byte versions (v17.12.03 & v 17.08.01). Still to no avail, alas.
I’ve tried them with ‘run as administrator’, and with registry settings both ways, rebooting each time.
I would welcome any help, but be advised I’m totally useless with computer tech, and will need simple things spelled out like I’m an idiot, because I am.
I’m also curious as to why I can only find the exe file as a download on my computer, does the main program live online or in the cloud?
Fyi, when I signed up to this forum, I had a flagged message 'greetings from discobot’, now I didn’t click on it, as one tends to distrust things calling themselves a bot …… is this site bot free?
Kind Regards.