Blank editing window

I have been using shotcut for several weeks and successfully created several videos, but now it just shows a black screen instead of the video being edited. The timeline is also blank, but I can hear the audio on the same track. It’s been a while since I messed with it so I don’t remember if I had changed any settings (I don’t believe that I did). However, I have tried a complete uninstall/reinstall three times with the same results.

I am running dual monitors, but the program worked with one and two monitors before, now it doesn’t work with either. I tried to set the “Display Method” setting to OpenGL, but that crashes the program upon startup and it needs to be reinstalled.

My rig:
Intel core i3 3220 (3.30GHz)
Nvidia GeForce GTX 960
Windows 7 Home

Try changing your Windows scaling back to 100% (96dpi)

Thanks for the reply, unfortunately that didn’t work.

in the process of editing your video…by any chance did you happen to attempt to overwrite, (save over), your original file exporting a new file of the same name? this is what happened while i was editing and i had the same result…my fix for exporting a file with the same name was to add a number to the end of the new file name…(01, 02, 03, and so forth), thus avoiding the overwrite.
i’m only guessing here, but that is exactly what i had done and was surprised by the exact same result.

Well, I eventually tried a rather unorthodox fix, and that was to upgrade to Windows 10. I had been resistant to upgrading my OS for a long while (if it ain’t fixed, don’t break it, or something like that), mainly due to the fact that I really hate upgrading unless I really have to (for instance, I stuck with Windows XP until Windows 8 came out).

But I noticed that I wouldn’t be able to upgrade my DirectX to version 12 unless I updated to Windows 10. So I finally bit the bullet and downloaded it, and fortunately it seems Shotcut works just fine now. I wish I could offer more of a solution to the hardcore Win7 users, but that’s the best solution I can offer at this point.

To be fair, I don’t know if DirectX has anything to do with the solution to my problem, but I do know that Windows 10 works with Shotcut now. Thanks for the suggestions, guys, and I hope that nobody has to suffer through the same bug I had to endure.

You won’t regret Windows 10. As good as Windows 7 was/is - Windows 10 is better :wink:

I am facing the same problem. My shotcut window appears blank but when I hover over my mouse I could see the menu but upon clicking to open a file the inside of the window remains blank. I had direct x version 12 installed , windows 10, openGL drivers from NVidia. I am not sure what is wrong. I need help.

Try the different options under the menu Settings > Display Method. If you cannot even see the menu, then try reinstalling using the installer and when you get to the installer screen with checkboxes, choose the option to remove the registry settings. If that does not work, then I think Shotcut is somehow incompatible with your system.

I faced similar issue. Go to Menu (though you cant see any, go with Alt+F and arrow keys to move around). In the Settings Menu, Go to “Display Method” and click on “Automatic” . This should bring back the display in entire window. The issue could be with DirectX (ANGLE) display method not working in some systems.

This is a good suggestion. Alternatively, if you have some technical ability (edit registry), you can manually set the drawMethod listed on the Configuration Keys page on the web site.