Black background for a specific video track when overlapping images

OP system: Windows 10
Shotcut version: 22.04.25

Context: I was trying to show some images over a wooden background.
Problem: For a specific video track, the background is black. Therefore, the wooden background doesn’t show.

Details:

On the first picture, you can see on the track V3 that I have an image with three filters in front of a wooden background. Everything works as intended.

On the second picture, however, for some reasons, the background is black.

Now, if I take the same image selected on the track V4 and I move it on the track V2, as shown in the third and last image, we can see the wooden background.

This doesn’t make any sense. It’s like the track V4 is acting differently than the track V2. This doesn’t have to do with the actual image, nor the filters, because if I simply move the image from V4 to V2, the wooden background appears as shown before. This really has to do with the video track V4. I have restarted the app and tried to delete every other video/image on the track V4, but it didn’t do anything.

More than likely it is not a bug, and there is not enough information. For the Size Position and Rotate filter for the image on V4, what is the Background color set to? You need to scroll the filter parameters UI downward to see it since your screenshot does not show it. What is the Blend mode of track V4 in Properties? Click the V4 track header, and view Properties. You also need to look at what is on V3 under V4’s image because that may also be a factor.

No idea if this is worth mentioning, but I’ve just noticed that every track except the track V4 has the property “blend mode over”. For some reasons, there is just no property for the track V4. I wouldn’t know if this is what is causing the issue.

To answer your question, even though the filters shouldn’t matter, the background color is set to default.

Aloha !

In your pictures I see you also use the “Fade In Video” filter.

Perhaps, and I could be completely wrong about this like @shotcut said too little info
so I am just wildy guessing, but perhaps the checkmark
“Adjust opascity instead of fade with black” is not ticked ??

.

Cheeeeeeeeeeeeers

Jecepede

Like I said, since I moved the image from one track to another, the filters don’t matter. Since it acts differently from one track to another without changing the filters, the problem must come from the track itself. I must assume it has to do with the tracks properties, but I wouldn’t know how to fix that. I’ll try something.

EDIT: I’ve noticed that the track V1 also doesn’t have a blend mode property. I’ve read online that this is normal, but I do believe it is not when it comes to the track V4.

EDIT2: When using the shortcut Alt+shift+ , it makes the property of the track disappear. This doesn’t happen when doing it manually.

– FIX –

I’ve resolved my issue by creating another video track, moving the track downward manually (without shortcuts) next to V4, moving every files on the new track and deleting the old V4 track.

– BUG (to be confirmed) –

My issue seems to come from a bug with the shortcuts. When using Alt+shift+ to move downward a video track, it removes the blend mode property of that video track resulting in a black background when trying to overlay different images and videos.

1 Like

Thanks for narrowing down the source of that bug. What a coincidence that another user today reported an upper track missing its blend mode in Properties. Probably the same.

1 Like

Yeah, that must be it.

My pleasure! :slight_smile:

Can anyone help me recreate this issue from an empty project?

Here are my steps:

  1. Open Shotcut
  2. Type “Ctl-I” to add a video track
  3. Add a blue color clip to the track
  4. Type “Ctl-I” to add another video track
  5. Add a red color clip to the track
  6. Observe that the properties for track V1 does not show a blend mode and the properties for track V2 show the blend mode “over”
  7. Select track “V2” (the top track)
  8. Type “Alt-Shift-Down” to move V2 down
  9. Observe that the properties for track V1 does not show a blend mode and the properties for track V2 show the blend mode “over” - this is the expected result

I am looking for a sequence of steps that will result in any track other than V1 showing no blend mode.

I’ve just tried it and I can’t reproduce it. I’ve thought for sure it was caused by the shortcut, but something else might have caused that issue.

Thanks for trying. That just means we haven’t found the secret steps to create the bug. Let’s all keep an eye out for it.

I assume this issues is the same as the issue here (which is fixed for the next release):