BETA version 24.06 now available to test

The release notes mention “Fixed using graphics (text, image, etc.) on upper video track with GPU Effects.” Is there more information available about what the problem was? I’m not a GitHub expert and my attempts to find closed issues or code changes with similar descriptions came up empty.

These Search results for '#bug tags:GPU order:latest' - Shotcut Forum

The fix for the track blending was in MLT, which is why you could not find it in Shotcut git.

1 Like

Anyone else getting a broken filter menu with this beta? Tried on new and old projects, seems completely random, but more often than not it’s completely white.

Tried removing it and adding it back, moving it around, changing layouts, etc… nothing fixes it.

I recall experiencing this only while working in Windows 11. Then, I noticed some updates had installed in the background and suggested a reboot to finish. I did, and then I did not have the problem again. Another thing to try is to close Filters, restart the app, and then open Filters.

Also, did you use the installer and install to the same location as the previous version without uninstalling? I see the somewhat new installer does not first remove the old version. I have not found a specific problem caused by this yet, but potentially it does when we do major updates to dependencies like we do in this version.

Just tried restarting with filters closed, same issue.

I did however use the installer and installed to the same location, I usually update this way, however this is the first time I’ve done it with a beta build. If I uninstall will I lose any presets?

EDIT: Also meant to say, no updates to install, on the latest version.

Uninstall does not remove presets.

Uninstalled, reinstalled the beta, same issue. Didn’t open any project files this time either, just opened the app and it’s like this.

EDIT: Wrong picture.

EDIT 2: Closed the filter menu, restarted the app, opened filters, same issue.

Just to add that I experienced this too - Windows 11. Happened twice, erratically. Unfortunately I can’t remember exactly what I was trying to do at the time, which Iknow is not much help. Sorry.

Just removed the Shotcut folder from appdata, still have the same issue and also did the same steps with closing filters and restarting.

Now your presets are gone unless you moved or renamed the folder or have a backup.

I backed them up, was just testing to see if it made a difference.

Can you please send me your View > Application Log in a private message?

Fedora 40 KDE Plasma. Shotcut Linux portable.

Wayland session.

X11 session.

For the white Filters panel, can I get you test a change in tomorrow from the next daily build? Even though I cannot reproduce it reliably enough to debug and test the fix, I reviewed the change that is the likely culprit and made a remedy.

Log sent, not sure if it’s still needed.

Thanks, I’ll give it a test tomorrow. :slight_smile:

@TJGM and @Chucky

Please test today’s daily build where I tried to fix the problem with Filters:


Linux Portable

1 Like

Your fix regarding the File > New bug seems to have solved the problem.
No more crashes with the latest Github build.

1 Like

Seems to have fixed it, thank you!

1 Like

Build 24.06.06.
Filter panel’s all good, Wayland and X11 sessions.

1 Like

Bug in version 24.06.06
The “Automatically Add Tracks” parameter is constantly reset. Even if you turn it off again and add new content to the timeline, the parameter still turns on on its own and two empty tracks are added.

1 Like