BETA version 23.09 now available to test

Please try our beta release for the next version due by the end of September, a nice little roundup of fixes and enhancements:


I just installed BETA 23.09

One problem occurred right from the start.
I wanted to check View > Resources… but on each try Shotcut crashes.
The dialog box appears for a few seconds, white content. Then Shotcut shuts down.

There’s 25 files in the Playlist and 2 clips in the Timeline.

Here’s the last shotcut-log, in case it can help.
shotcut-log.txt (36.0 KB)

Love the new Backup and Save option!
Great addition.

Name given to the backup file:

But the file was saved on: 2023-09-02. Local time: 19h 05m XXs (approximately).

– EDIT –

Ok… now it seems to be working properly. I don’t know why it didn’t work on my first try.

I also experienced problems with the Keyframes panel:

  • Add a clip to the Timeline (in my case, a 4-sec image)

  • Add a filter.

  • Switch to the Keyframes panel.

  • Click on the Zoom to Fit button:

Most of the times the clip is zoomed to maximum instead of fitting the width of the panel.
Sometimes it works fine on the first try.
Sometimes the clip get zoomed to fit the panel after 1 or 2 more clicks on the button
Sometimes it took a lot more clicks. Like between 5 or 10 more clicks.

In the capture below, it worked after only 2 clicks.


  • In the Keyframes panel, manually increase or decrease the zoom of the clip.

  • Switch to the Timeline panel, then back to the Keyframes panel

The zoom gets back to the default zoom value.


Not related to the Keyframes panel, but since we’re not allowed to create more than 3 consecutive posts, I add the following bug report in this post.

I also experienced a problem with the DeClick filter:

Shotcut crashes if I increase the Window parameter to somewhere above 67ms

shotcut-log.txt (69.0 KB)

Good morning and have a nice Sunday

Shotcut takes a little longer to start it seems, on the first try, no way to drag and drop a file, I closed it and then it’s good.
My little problem was produced a priori with the mouse, I ended up with the full screen with the lower part of the timeline reduced. To get the normal appearance back, I loaded a file and it came back, but I would like to know how I did so the two tracks that I had disappeared from the field of vision.

What is

Fixed Export or turning off Settings > Proxy > Use Proxy if the file starts with a data stream such as videos recorded on Google Pixel phones, for example.

about? I would like to use proxies and here it seems it is automatically deactivated. Is that so? What is the root cause of those videos recorded by Pixel phones?

In your capture the layout is set to Player (Lecteur)

Switch it back to Editing (Montage)

Too late Musicalbox, good evening. Then, I lost the views in the attached image. I restored the default layout, and reverted to my usual layout (I’m not sure, but I think the one I saved was deleted or didn’t appear). I backed up and it seems stable since then.


Please explain that more. I do not understand. The description in the release notes in pretty self explanatory, but it does require an understanding of multiplexing streams in a media file and that in addition to audio and video they can be text and data. This is a bug fix for using proxies with incompatibilities with video recorded with a Google Pixel phone reported here several times. The bug is a technical and had to do with using an absolute stream index value in the MLT XML for the default or chosen audio and video streams - that relates to Track field in Properties > Video and Audio tabs.

In a Google Pixel phone, the first stream is some timed data, which Shotcut ignores, but it still requires an absolute index (prior to this fix). So, stream indices were set to audio_index=1 and video_index=2. However, when making a proxy, the useless data track is ignored. This makes the proxy’s audio_index=0 and video_index=1. Shotcut (via MLT) then ends up writing MLT XML using the proxy’s indices, but the conversion from proxy to source does not know how to do a mapping. The fix was to change things to relative index values: the n-th audio stream and n-th video stream. These now show up in MLT XML as “astream” and “vstream” properties. (However, audio_index and video_index properties must also stay for reasons I will not explain. In any case, it needs to be backwards compatible with projects that have only those.)

1 Like

This is fixed for the release.

This is a side effect of the fix for this one:

The GUI library does not allow Shotcut to distinguish between the visibility changing due to docking or changing tabs. I probably won’t make any more changes to this before the release.

1 Like

I reported earlier that I experienced crashes when using 2 of the new features (DeClick filter and .View > Resources).

But sadly, after more tests, I also experienced random crashing when performing simple operations. Like grabbing and dragging a clip from the Playlist to the Timeline for example. Or moving a clip from one track to another. Things I very, very rarely had problems with on previous versions.
I don’t have more details about that for now, but I’ll try to take notes and save the app logs the next times it happens.

But I’d also like to ask if someone else experienced this new instability in the 23.09 BETA version. Maybe it’s just some random incompatibility with my computer.

This is fixed for the release.

1 Like

Yes. I believe the problem causing the View->Resources crash is more prolific than just that window. I think, that for now, it is best to limit testing of this beta to only having two clips in the project at a time.

I have a fix in review that will hopefully return the stability.

1 Like

This is fixed. There will be another pre-release for this version.

1 Like

When I did an export I had this strange DOSlike windows talking about MELT.EXE.
It ran to 100% or down to 0% can’t remember.
It did not affect the render on this beta but I have never used or seen melt.exe before.

I did not reproduce that on Windows 11. I believe it was caused by the memory problems already reported and addressed. Try restarting Shotcut and try it again to see if it happens again.

I have never used or seen melt.exe before

Shotcut has always run melt.exe as the background program for export, but normally the window is hidden. If you do an export in any previous version and view the Windows Task Manager > Details you can find melt.exe running and the end of Shotcut View > Application Log shows the command line it ran similar to:
[Debug ] <MeltJob::start> "C:/Users/ddenn/Downloads/shotcut-win64-230902/Shotcut/melt -verbose -progress2 -abort xml:C%3A%2FUsers%2Fddenn%2FAppData%2FLocal%2FTemp%2Fshotcut-eEZnNq.mlt"
(In Windows, the command line does not need the “.exe” part of a program to run it.)

@shotcut @brian
I want to ask you very much to add a keyframe for the “Focal Ratio” parameter of the “Fish Eye” filter. It is sorely lacking for creating interesting special effects and transitions. The possibilities of the Lens Correction filter unfortunately do not give those amazing results that you can get using the Fish Eye filter. I’m only asking for keyframes for the Focal Ratio parameter, that will be enough. Please :slight_smile:


Do you have Avast antivirus? Or some other antivirus with real time + sandbox scanning?

This always happens to me for the beta versions the first time I run shotcut, it detects an “unknown/new” program and runs it in a sandbox, it usually does it for 30s at startup for shotcut.exe then right as I export it shows the melt.exe in a cmd window (again for 30s) then decides the application is safe and it disappears forever (for this version).

In the release notes I saw this line:

  • Improved the color dialog on GNOME.
    But this window is exactly the same as in the previous release:
    I’m using Linux Mint 21.2 Cinnamon

For comparison, this is what the color selection dialog looked like in version 12.22.21: