Bend lines


Does anyone have some tips on how to eliminate these bend lines after Shotcut exports the video?
On the right side, a picture is from the native Gopro video, and the left side is after it is exported.

I’m using the same resolution, same framerate, and aiming to be at least the same video bitrate which is 100Mbps.

I had to enlarge the picture to full-screen to see the lines, which appear to be due to color banding. See the following post for a possible solution and let us know if that solves the problem:

This is assuming you are exporting to MP4. Please share your export parameters and Shotcut version.

Hi Elusien,

I get it a bit better but still with lines.
You can see current settings, and I am using the latest Shotcut version.

The exported file is 276Mbps which is almost 3x of the native video.

I see you are using hardware encoding. Until recent generations of GPUs this produced slightly worse quality than software encoding. I’d be tempted to try Software encoding (deselect the option) and see if that sorts out the problem. If it does then try with the default parameters as the increased file size is due to the quality being set to 75%. You might want to try 65% if the 55% isn’t good enough as 75% is overkill.

Ok, I will export now without hardware acceleration.

What does tune=grain do? :slight_smile:

I would first try just the default export settings, not the ones you changed, since I suspect it is the Hardware encoding that is causing the color-banding. I would also try just changing quality to 65% if you still get some banding.

The ffmpeg options (including tune=grain) are described here:

Ok I should just turn off hardware encoding and use libx264 (which is set by default), without any other tunning?

That’s what I would try first. If it isn’t good enough try Quality=65%.

Ok tried this, it took 5x more time to export the same video, quality is same bending lines are present, but what is different, the file size, which is almost twice smaller. But I think I will keep hardware encoding and set the additional setting like in the post you pasted. It best quality/time/speed solution.

If you haveother ideas, please share :slight_smile:
Thank you.

This topic was automatically closed after 90 days. New replies are no longer allowed.