Automatic (unwanted) deinterlacing?

Hi all,

I have problems getting proper interlaced output with Shotcut 20.07.11.

I am working on a few old, but personally important SD videos (Super-8, VHS - i.e. all interlaced) using some advanced Avisynth scripts for cleaning them up. Furthermore, I am always using FFV1 as intermediate codec for all steps until the final x264 encoding.

I worked with FFV1 files before in shotcut and set every clip to “Interlace” and “Top/Bottom Field” manually after having loaded them into the playlist. On export, I chose FFV1, again “Interlace” and “Top/Bottom Field” enabled, and it works when I just put the clips next to each other in the timeline and add simple cross-dissolve transitions and fade-in/fade-out. Project settings are of course also set to PAL DV (i.e. 720x576, interlace enabled, 25fps etc.)

Now, I wanted to “repair” an stabilization error in one of my videos using the scale and rotate filters and keyframe editing. However, whatever export option I chose, I now always get an progressive output file with 25p instead of 50i.
I know that scaling filters need deinterlacing before being applied to interlace video material, but when I select interlace output, I assume that the affected parts of the video would be re-interlaced after internal composition, while the scenes, where the scaling filters are not applied, are output “1:1”.

Any hints what could have went wrong in my setup?
If this is a limitation of Shotcut (found a hint saying “use filters in shortcut for automatic deinterlacing”), I would regard this being a bug because I am not used to get progressive output (with half frame rate) when I select “interlaced” in the output settings or doubled frames when selecting progressive output with the frame rate set to 50p.

Thanks in advance for any answer!

This is by design because these filters are not field-aware. Basically, anything that affects the vertical resolution causes a deinterlace. This is not a bug; it is a limitation with no plans to change it as interlace output is not important to the current developers. Anyone interested in this must work on it theirself.

It´s confusing to not be informed about forced deinterlacing and having the export settings ignored. Setting the export to interlace and getting a non-interlaced result is a bug in my opinion. Or not having the option to output it progressive with double frame rate.
I call this a bug because the described behaviour (having material deinterlaced for effects and the reinterlaced on output) has been a standard for >25 years, and interlace material is available for ages.

But if there is no interest for the developers for now, I will have to deal with it.