Audio Visualization Filter


#1

Possible bug with Audio visualization filter.
If the size or position is changed in any way, by way of direct keyboard entry or dragging with the mouse, it gets ridiculously large values for position and size.
Clicking on the values and entering new ones or backspacing/deleting makes no difference.

Using version 18.09.16 on Mac 10.11.6 (El Capitan).


#2

Does it look similar to this post? Shake preset doesn't work


#3

That is the exact problem.
Any solution found?


#4

Nothing yet. There is a workaround pointed out by @QDSOV in reply #7 & #17 but that only applies to that specific filter preset.


#5

Pity, I guess will have to do it externally and then bring it in.


#6

Hi @Paul2
Are you saying that when you use the audio visualisation you can’t size and position it where you want on screen like is shown in the screenshot below?

If that’s your problem, you don’t need to use the S&P filter at all. You can resize and reposition the AV filter from within it’s own dialogue. A box similar to the S&P filter appears with an anchor in the centre you can use to drag it and resize using the corners. The screenshot below shows the filters used on that clip and, as you can see, no S&P and the box for the AV filter is visible.

If that’s what you’re already doing, then if it is a bug, maybe it’s specific to the version you are using. You might need to look at your project or reinstall Shotcut with a newer version. The images above came from version 18.11.13 (Windows)


#7

Correct.

Tried that too, same thing, the values for the size and position just go bonkers, into the tens of thousands.
It’s almost like the original values are being multiplied by the new values.


#8

We have had some problems when your decimal separator setting differs from your general locale/region setting. Does the Size and Position filter alone, not in conjunction with Audio Visualization, work OK? These AV filters use some different MLT property-setting methods than Size and Position, and that will be a clue.


#9

Interesting.
It’s a Mac Book Pro issued by the studio so not sure how it’s set up.

Yes it does.

Below, screenshot of size and position if I modify the mlt file in a text editor:

41%20PM

Once I drag the block somewhere else:

and the corresponding mlt file (saved by Shotcut):

17%20PM


#10

This has been fixed for the next version 18.12


#11

Many thanks.