Audio/Video sync after export

I’m a new forum member. I’ve searched some threads but haven’t nailed down a working answer. After export (to mp4), my video doesn’t sync with audio (video is late).

I don’t think I’m using variable frame rate. My source videos were taken with a Zoom Q8 and the properties box lists everything with a frame rate of 29.97.

I saw some comments about processing the files through ffmpeg. Is that the only solution? I’ll have to develop some better terminal skills in order to make that work. I did watch that one video explaining how to use ffmpeg but got stuck.

Is there another setting/solution I’m not thinking of?

My Shotcut version is 19.04.30. I’m using Mac OSX 10.10.5 Yosemite.

FWIW I did have to slow down some video clips so they would line up with a separate audio track.

Here’s a screenshot of the properties box.

Are you changing resolution or frame rate in Export? This is frequently mentioned, but you did not mention it. That is the main culprit. If you see a sync problem in preview, you can adjust it in Properties > Audio.

If you are trying to sync this speed-adjusted video with that audio track, then it is going to be difficult. Are these the two things that are out-of-sync?

You might need to try to convert some files to see if it helps, but you do not need to use the command line. Shotcut has Properties > menu > Convert… that will create a job, and you need to double-click the job when it is done to open and use the result.

For export, I think I was using automatic settings. I don’t believe I tinkered with frame rate at that point.

Things are well-synced when I play the video in Shotcut. To add a bit more information: I did a recording session with two Q8’s. We are now editing the final takes of the audio and, after many takes, the final version varies slightly from our first complete take for the video cameras. Yes, it was tricky but I managed to make it work within Shotcut. However, the video/audio are way out of sync in the mp4.

That’s something I haven’t done before. I’ll have to hack around with it for a while. I’ve only been seriously trying to figure out Shotcut for a few days. I love it except for this vexing problem right at the end.
Thanks for your help!

This topic was automatically closed after 90 days. New replies are no longer allowed.