Audio track sometimes plays, sometimes not

I’m working on a project with a separate audio track created with a number of .aac files laid in the correct relationship to video. I didn’t convert them on opening and wonder if that is why the track is misbehaving? It is hit and miss which parts of the track (ie which files) play - sometimes none of it, sometimes some of it, never all of it. (At least not today; yesterday it was all working fine and I exported successfully as well.) When a file does play then the audiometer shows, otherwise not. The volume control is fine. There are no filters on the audio tracks. I must have done something stupid to make the project unstable; can anyone give me a hint?

Can you share a screenshot of your Shotcut screen with the properties panel showing for one of your clips?

Thanks Brian
I attach the requested screenshot below. The second audio clip shown was working a few minutes earlier but I decided to shift it to the left (to align the voiceover better with the video) and then it didn’t work at all. I wondered whether I wasn’t allowing enough time for it to realign itself (forgive my lack of technical vocab!) and by pressing play too soon after the shift had somehow caused it to ‘lose’ or corrupt the clip? When I hit the same issue with the first audio clip, I couldn’t get it to play whatever I tried (including closing and re-opening Shotcut). Eventually, I removed it from the playlist and loaded a .wav file instead which worked.

I find that, as I try to align the voiceover cllips, this is when I might lose the sound. Also, even if the sound is playing, it may not be in line with the audio waveform. Perhaps I am expecting too much?

Another strange thing is that I initially added all the .aac files via ‘Open File’ and they showed in the playlist immediately. When I came to add a few more and the .wav version of the first one, I found that this didn’t work; the only way I could get them in the playlist was to drag and drop.

I would guess the problem is the container. It’s an AAC file stored directly in a .aac file. Where did this file come from? FFmpeg doesn’t read .aac very consistently. AAC usually reads best in an MP4 or MKV container. Is there a chance you could transcode or remux it into one of those containers? If you’re a command line user, you could do one of these:

ffmpeg -i "myfile.aac" -c copy "myfile.m4a"


ffmpeg -i "myfile.aac" -c copy "myfile.mkv"

or convert them to WAV. As you noticed earlier, wav files don’t have these problems. That’s why I lean towards the .aac container being the problem (assuming there even is a container and it isn’t just a raw stream).

I agree. This would be the first thing to try. Instead of using ffmpeg, the user could click the “convert” button in the properties panel.

Thank you both (Austin, Brian) for your suggestions. I tried to install ffmpeg but got into a muddle with the procedure and ended up without a vital .dll apparently. So I tried the built-in conversion procedure. The original .aac files were made on my phone (microphone input on my desktop having failed) and I don’t know whether they were in a container or not (this whole subject is kind of over my head!). Anyway, unless I missed a trick, it seemed that each file had to be put in the source window before I could see its properties and effect a conversion (to the defaullt .mp4 container at the basic level). This seemed to be alright except for one file which would not behave. An attempt to drag it into the playlist would bring up two little windows (one named ‘Add files’ which I could close and one named ‘Set duration’ with a 5-second duration set; I could only get out of that by 'Cancel’ing as ‘OK’ did nothing). The file played fine in other software but there must have been something about it which Shotcut didn’t like and I decided to do without it.

So I then plonked the (17) successfully converted files on the (new) audio track in what seemed to be the right place and all went swimmingly for a while. But then I realised that the conversion process had not solved the basic problem. If I tried to move the audio clips forward or back to improve the alignment with the video I would either lose a little of the clip or else lose sound altogether next time I played it or sometimes hear sound from a clip nowhere near the playhead. It may be that there is a bug in the system and that too many separate clips with gaps between is beyond the scope of the software? But I still think it more likely that I am doing something stupid.

This topic was automatically closed after 90 days. New replies are no longer allowed.