Audio track change removes clip when ripple all tracks is on

What is your operating system?
Windows 11 - Home (22H2)

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?

  1. Create Video and Audio tracks on timeline
  2. Add suitable clip to video
  3. Add multi-track audio clip to audio track
  4. Open properties of clip on audio track and change audio track of clip
  5. If Ripple All Tracks is enabled then clips on other tracks will be removed.

Apologies if this is intended behaviour but I don’t remember previous version doing this.

Quick screen capture of steps

This is fixed for the next version 24.06. The problem occurs with any change in Properties such as track, color range, or rotation. The only change where there should be a ripple on other tracks is speed change.

1 Like